Bug 837524 - Malformed fontconfig config file
Malformed fontconfig config file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wqy-zenhei-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
: 837551 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 03:51 EDT by Akira TAGOH
Modified: 2012-09-06 22:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 22:53:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-07-04 03:51:54 EDT
Description of problem:

Still no changes in the behavior in the latest version of fontconfig,
but it now warns when <test> contains multiple values or <alias> contains
multiple <family>s. this is because the behavior isn't intuitive and
doesn't work as expected necessarily. So you better consider to fix it
to make clearer what you want to do with it.

For solution, if you are expecting OR operator with that rule, add more
<match>s or <alias>es. if you are expecting AND operator with that rule,
just add more <test>s in that <match>.

Version-Release number of selected component (if applicable):
wqy-zenhei-fonts-0.9.46-3.fc17.src.rpm

How to reproducible:
always

Steps to Reproduce:
1. install the fonts package
2. fc-match

Actual results:
Fontconfig warning: "/etc/fonts/conf.d/65-0-wqy-zenhei-sharp.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-wqy-zenhei-sharp.conf", line 27: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-wqy-zenhei-sharp.conf", line 46: Having multiple values in <test> isn't supported and may not works as expected

Expected results:
no warnings
Comment 1 Peng Wu 2012-07-10 02:30:58 EDT
*** Bug 837551 has been marked as a duplicate of this bug. ***
Comment 2 Peng Wu 2012-07-10 03:33:23 EDT
Rebuilt for rawhide.
Comment 3 Fedora Update System 2012-07-11 22:11:43 EDT
wqy-zenhei-fonts-0.9.46-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wqy-zenhei-fonts-0.9.46-4.fc17
Comment 4 Fedora Update System 2012-07-12 14:57:19 EDT
Package wqy-zenhei-fonts-0.9.46-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wqy-zenhei-fonts-0.9.46-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10579/wqy-zenhei-fonts-0.9.46-4.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-07-20 22:53:49 EDT
wqy-zenhei-fonts-0.9.46-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Akira TAGOH 2012-09-06 22:26:29 EDT
Since the behavior itself isn't changed in fontconfig, it may also affects to f16 that is still supported in Fedora. so can you push an update for f16 too?

Note You need to log in before you can comment on or make changes to this bug.