Bug 837532 - Malformed fontconfig config file
Summary: Malformed fontconfig config file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sazanami-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-04 07:52 UTC by Akira TAGOH
Modified: 2012-07-04 10:23 UTC (History)
3 users (show)

Fixed In Version: sazanami-fonts-0.20040629-18.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-04 10:23:47 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2012-07-04 07:52:43 UTC
Description of problem:

Still no changes in the behavior in the latest version of fontconfig,
but it now warns when <test> contains multiple values or <alias> contains
multiple <family>s. this is because the behavior isn't intuitive and
doesn't work as expected necessarily. So you better consider to fix it
to make clearer what you want to do with it.

For solution, if you are expecting OR operator with that rule, add more
<match>s or <alias>es. if you are expecting AND operator with that rule,
just add more <test>s in that <match>.

Version-Release number of selected component (if applicable):
sazanami-fonts-0.20040629-17.fc17.src.rpm

How to reproducible:
always

Steps to Reproduce:
1. install the fonts package
2. fc-match

Actual results:
Fontconfig warning: "/etc/fonts/conf.d/65-4-sazanami-gothic.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-4-sazanami-mincho.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected

Expected results:
no warnings

Comment 1 Akira TAGOH 2012-07-04 10:23:47 UTC
Fixed in sazanami-fonts-0.20040629-18.fc18


Note You need to log in before you can comment on or make changes to this bug.