This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 837535 - Malformed fontconfig config file
Malformed fontconfig config file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kurdit-unikurd-web-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 03:53 EDT by Akira TAGOH
Modified: 2012-07-05 06:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: kurdit-unikurd-web-fonts-20020502-8.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 06:16:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-07-04 03:53:04 EDT
Description of problem:

Still no changes in the behavior in the latest version of fontconfig,
but it now warns when <test> contains multiple values or <alias> contains
multiple <family>s. this is because the behavior isn't intuitive and
doesn't work as expected necessarily. So you better consider to fix it
to make clearer what you want to do with it.

For solution, if you are expecting OR operator with that rule, add more
<match>s or <alias>es. if you are expecting AND operator with that rule,
just add more <test>s in that <match>.

Version-Release number of selected component (if applicable):
kurdit-unikurd-web-fonts-20020502-7.fc17.src.rpm

How to reproducible:
always

Steps to Reproduce:
1. install the fonts package
2. fc-match

Actual results:
Fontconfig warning: "/etc/fonts/conf.d/65-kurdit-unikurd-web.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected

Expected results:
no warnings
Comment 1 Parag Nemade 2012-07-05 06:16:52 EDT
Fixed in kurdit-unikurd-web-fonts-20020502-8.fc18

Note You need to log in before you can comment on or make changes to this bug.