Bug 837583 - [regression] Error occurs when run virsh blockcopy command
[regression] Error occurs when run virsh blockcopy command
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 06:16 EDT by hongming
Modified: 2012-09-10 04:51 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 14:50:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hongming 2012-07-04 06:16:19 EDT
Description of problem:

The following error occurs when run  blockcopy command. It can't be reproduced in libvirt-0.9.10-21.el6.x86_64.
error: unsupported flags (0x8) in function qemuDomainBlockRebase

Version-Release number of selected component (if applicable):
kernel- 2.6.32-276.el6.x86_64
libvirt-0.9.13-2.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64


How reproducible:
100% 

Steps to Reproduce:
1.Create domain
# virsh create qed-rhel6.3.xml
Domain qed-rhel6.3 created from qed-rhel6.3.xml

2.virsh blockcopy qed-rhel6.3 vda /var/lib/libvirt/images/copy_target --bandwidth 1
error: unsupported flags (0x8) in function qemuDomainBlockRebase

  
Actual results:
The following error occurs
error: unsupported flags (0x8) in function qemuDomainBlockRebase

Expected results:
virsh blockcopy command can run successfully.

Additional info:
Comment 1 hongming 2012-07-04 06:21:09 EDT
It's not related to options ,without --bandwidth ,it still can be reproduced.
Comment 4 Eric Blake 2012-07-11 17:13:40 EDT
Same issue as bug 837787 - we compiled out the RHEL-specific patches from RHEL 6.3 in the hopes that upstream qemu will settle on a final block copy setup; if that is too slow in happening, we can re-instate the RHEL-specific patches.

*** This bug has been marked as a duplicate of bug 837787 ***
Comment 5 zhenfeng wang 2012-09-07 06:12:07 EDT
Description of problem:
it reported error when run the command "virsh blockcopy testhd vda /var/lib/libvirt/images/bak"

Version-Release number of selected component (if applicable):
libvirt-0.10.1-1.el6.x86_64
qemu-kvm-0.12.1.2-2.305.el6.x86_64
kernel-2.6.32-298.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. prepare a guest xml and create it

2. dumpxml
...
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/var/lib/libvirt/images/testhd.img'>
        <seclabel relabel='no'/>
      </source>
      <target dev='vda' bus='virtio'/>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>
...

3.
# virsh blockcopy testhd vda /var/lib/libvirt/images/bak
error: unsupported flags (0x8) in function qemuDomainBlockRebase

4.
# virsh blockcopy testhd vda /var/lib/libvirt/images/bak --finish --wait
error: unsupported flags (0x8) in function qemuDomainBlockRebase

How do we soleve this problem ,reopen a new bug or other ways?
Comment 6 zhenfeng wang 2012-09-07 06:17:20 EDT
the duplicate bug 837787 is verified, but the problem still exisit as in comment #5

also tested in latest qemu : 
qemu-kvm-rhev-0.12.1.2-2.312.el6.x86_64
Comment 7 dyuan 2012-09-07 06:32:48 EDT
Reopen this bug to track the existing issue.
Comment 8 Eric Blake 2012-09-07 07:40:57 EDT
qemu 1.2 missed Paolo's drive-mirror patches; he's hoping to queue them up shortly for qemu.git in time for 1.3, so there's still a chance that upstream libvirt will have patches for block-copy rather than having to have lots of RHEL-specific patches.  Unfortunately, that means we are still playing a waiting game (although I _am_ maintaining a rebased patch series on my local tree to deal with things even if upstream doesn't move fast enough).  Whatever happens, you can expect the RHEL build of 0.10.2 later this month to fix the regression.
Comment 10 Dave Allan 2012-09-07 14:50:00 EDT
I'm going to reclose this BZ, as it shouldn't have been tested yet.  If, after we put the code back into the release, it reproduces, please reopen.

Note You need to log in before you can comment on or make changes to this bug.