Bug 837628 - PXE/NFS anaconda install hangs on reboot
PXE/NFS anaconda install hangs on reboot
Status: CLOSED DUPLICATE of bug 824191
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 08:54 EDT by bob mckay
Modified: 2013-01-10 01:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 13:21:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (2.62 KB, application/octet-stream)
2012-07-04 08:54 EDT, bob mckay
no flags Details
install log (45.69 KB, text/plain)
2012-07-04 08:55 EDT, bob mckay
no flags Details
install syslog (10.40 KB, application/octet-stream)
2012-07-04 08:55 EDT, bob mckay
no flags Details
Install screen showing hang (58.27 KB, image/jpeg)
2012-07-04 09:19 EDT, bob mckay
no flags Details

  None (edit)
Description bob mckay 2012-07-04 08:54:33 EDT
Created attachment 596214 [details]
kickstart file

Description of problem:
An otherwise-successful pxe/nfs install from a mounted, unpacked iso hangs on reboot. After exit from the installer, I see a successful shutdown of the network interface by NetworkManager that completes before unmounting of the filesystems, which inevitably results in "Could not unmount /run/install/repo: Device or resource busy". 

Version-Release number of selected component (if applicable):
Anaconda from an F17 64-bit install DVD (sorry, I'm not clear how I figure out the version).

How reproducible:
100% reliable

Steps to Reproduce:
1. pxe/tftp, pivot to
2. anaconda/nfs using kickstart file
3. automatically reboot
  
Actual results:
Reboot hangs waiting for nfs mount of iso to unmount

Expected results:
Reboot completes

Additional info:
I'm not sure if this is a duplicate of bug 824191 or one of the security-hidden bugs referred to there (couldn't quite work out what symptoms they were describing). However I did try putting updates.reboot.img in the images directory, and that didn't help. So I'm guessing it's different.
Comment 1 bob mckay 2012-07-04 08:55:06 EDT
Created attachment 596215 [details]
install log
Comment 2 bob mckay 2012-07-04 08:55:40 EDT
Created attachment 596216 [details]
install syslog
Comment 3 bob mckay 2012-07-04 08:58:05 EDT
Oops, sorry, this was a 32-bit install rather than 64-bit, unpacked from the F17 32-bit install DVD.
Comment 4 bob mckay 2012-07-04 09:19:01 EDT
Created attachment 596221 [details]
Install screen showing hang
Comment 5 Jesse Keating 2012-07-05 13:21:23 EDT

*** This bug has been marked as a duplicate of bug 824191 ***

Note You need to log in before you can comment on or make changes to this bug.