Bug 837646 - irqbalance cloggs log file
irqbalance cloggs log file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: irqbalance (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Petr Holasek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 10:44 EDT by Aron Vrtala
Modified: 2016-10-04 00:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:54:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output gzipped. (18.43 KB, application/x-gzip)
2012-07-04 10:44 EDT, Aron Vrtala
no flags Details

  None (edit)
Description Aron Vrtala 2012-07-04 10:44:51 EDT
Created attachment 596231 [details]
dmesg output gzipped.

Description of problem:

This is the same problem as described in closed bugs 781578 and 755570. This system runs on bare metal an not in a VM (CPU Intel(R) Xeon(R) CPU E31225 @ 3.10GHz stepping 07). The system has been freshly installed with Fedora 17 and yum updated.

The following message appears every 10-60 seconds.  No other irqbalance messages appear in the log.

/usr/sbin/irqbalance: Load average increasing, re-enabling all cpus for irq balancing


Version-Release number of selected component (if applicable):

irqbalance-1.0.3-4.fc17.x86_64

How reproducible:

Allways.

Steps to Reproduce:
1. Install Fedora 17.
2. Run OS.
3.
  
Actual results:

Message appears at least 3 times a minute clogging /var/log/messages.


Expected results:

The message really should only appear occasionally.


Additional info:

dmesg output.
Comment 1 Aron Vrtala 2012-07-05 00:36:24 EDT
I've set up an older machine with Fedora 17. Patchlevel is same.

CPU is however: Intel(R) Core(TM) i7 CPU 920  @ 2.67GHz stepping 04

No hypervisors involved.

No irqbalance messages get logged!
Comment 2 Neil Horman 2012-07-05 09:39:49 EDT
Petr, this probably needs to just get gated on powerthresh not being UINT_MAX.  Can you please work up a patch for that?  Thanks!
Comment 3 Petr Holasek 2012-07-12 10:33:44 EDT
Hi,

fix was commited into upstream: http://code.google.com/p/irqbalance/source/detail?r=4e7df9d0b5416add20fe10925d82f145d3514715

New fedora irqbalance release should hit fedora-testing repo till the end of the week.
Comment 4 Aron Vrtala 2012-07-18 03:17:55 EDT
Hi,

I tried to install new fix from testing repo, still however it displays:

# yum install *irqbalance* --enablerepo=updates-testing
Loaded plugins: langpacks, presto, refresh-packagekit
Package 2:irqbalance-1.0.3-4.fc17.x86_64 already installed and latest version
Nothing to do

Should I try to apply the patch myself or wait?
Comment 5 Petr Holasek 2012-07-18 05:22:22 EDT
Hi Aron,

there is some delay in package release, because we want to fix more bugs in this release and unfortunately not all of them are closed yet. Could you please try to test the latest upstream version with commit noted in comment #3 included?

thanks,
Petr H
Comment 6 Fedora Update System 2012-08-23 10:12:16 EDT
irqbalance-1.0.3-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/irqbalance-1.0.3-6.fc18
Comment 7 Fedora Update System 2012-08-23 11:37:50 EDT
Package irqbalance-1.0.3-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing irqbalance-1.0.3-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12570/irqbalance-1.0.3-6.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-29 11:06:39 EDT
irqbalance-1.0.3-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/irqbalance-1.0.3-7.fc18
Comment 9 Fedora Update System 2012-08-29 11:18:56 EDT
irqbalance-1.0.3-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/irqbalance-1.0.3-6.fc17
Comment 10 Fedora Update System 2012-09-03 07:26:28 EDT
irqbalance-1.0.3-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/irqbalance-1.0.3-8.fc18
Comment 11 Fedora Update System 2012-09-17 19:54:30 EDT
irqbalance-1.0.3-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-09-18 22:59:36 EDT
irqbalance-1.0.3-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.