Bug 837679 - all fedora 17 custom spins crash when booting with dracut warning: unable to process initqueue
all fedora 17 custom spins crash when booting with dracut warning: unable to ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 13:48 EDT by upgradeservices
Modified: 2013-07-31 19:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 19:58:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init.log (307.51 KB, text/plain)
2012-07-05 14:06 EDT, upgradeservices
no flags Details

  None (edit)
Description upgradeservices 2012-07-04 13:48:41 EDT
Fedora 17 every custom spin fails with unable to process initqueue
tried making a custom spin of Fedora 17.

used basic kickstart:
cdrom
firewall --enabled
network --hostname=somehost
xconfig --startxonboot
firstboot --disabled
selinux --permissive
keyboard us
lang en_US.UTF-8
authconfig --enableshadow --passalgo=sha512

repo --name=flive0 --baseurl=file:///fx64/live_repo --cost=10

repo --name=fedoraupdates --mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f17&arch=i386 --cost=20
repo --name=fedora --mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-17&arch=i386 --cost=40

repo --name=fusionfreeupdates --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-17&arch=$basearch --cost=60
repo --name=fusionfree --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-17&arch=$basearch --cost=70
repo --name=fusionnonfreeupdates --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-17&arch=$basearch --cost=80
repo --name=fusionnonfree --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-17&arch=$basearch --cost=90

%packages
@core
anaconda-runtime
bash
kernel
passwd
policycoreutils
chkconfig
authconfig
rootfiles
fedora-logos
fedora-release
%end

%post
/usr/sbin/useradd -m la
/bin/echo "lalalala" | /usr/bin/passwd --stdin la
/bin/cat >> /etc/gdm/custom.conf << FOE
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=la
FOE
%end

%post --nochroot

%end

collected the packages:
setarch i686 pungi --name=somename --ver=somever --destdir=/f/p_dest_x86 --cachedir=/f/p_cache_x86 --nosource --force --config=/ksx86.cfg -G -C

built the iso:
setarch i686 pungi --name=somename --ver=somever --destdir=/f/p_dest_x86 --cachedir=/f/p_cache_x86 --nosource --force --isfinal --config=/f/ksx86.cfg -B

setarch i686 pungi --name=somename --ver=somever --destdir=/f/p_dest_x86 --cachedir=/f/p_cache_x86 --nosource --force --isfinal --config=/f/ksx86.cfg -I

built completed successfully, no errors.

but every time the iso created is booted it fails with this error immediately after grub screen is up:

dracut warning: unable to process initqueue
Dropping to debug shell

kernel 3.4.3-1.fc17
dracut dracut-018-40.git20120522.fc17
Comment 1 Harald Hoyer 2012-07-05 09:55:18 EDT
also with: https://admin.fedoraproject.org/updates/FEDORA-2012-9847/dracut-018-78.git20120622.fc17 ??

Please add "rd.debug quiet" and attach /run/initramfs/init.log
Comment 2 upgradeservices 2012-07-05 14:05:41 EDT
updated yesterday to:
dracut-018-78.git20120622.fc17.noarch
kernel-3.4.4-3.fc17.x86_64

crash persists.
init.log attached.
Comment 3 upgradeservices 2012-07-05 14:06:11 EDT
Created attachment 596466 [details]
init.log
Comment 4 Harald Hoyer 2012-07-06 01:18:57 EDT
root='live:CDLABEL=fx64x20F17x20i386'

and dracut checks for 
/dev/disk/by-label/fx64x20F17x20i386

that's all ok. You might want to add the pollcdrom dracut module to the install DVD initrd.img
Comment 5 Harald Hoyer 2012-07-06 01:25:09 EDT
You might want to add the pollcdrom dracut module to cope with faulty CDROMs and not rely on kernel CDROM polling :)

http://git.fedorahosted.org/git/?p=lorax.git;a=commitdiff;h=c143d5b72d1d2eddb2c42b03fd4c921447cc3df2
Comment 6 Harald Hoyer 2012-07-06 01:26:38 EDT
try to boot with "root=live:/dev/sr0" to see, if your cdrom is the culprit.
Comment 7 upgradeservices 2012-07-06 11:37:11 EDT
tried booting with root=live:/dev/sr0 - same.
this is a vm in the latest virtualbox 4.1.18, haven't had any issues with the crdom.
i can boot from fedora iso without any issues.
Comment 8 Fedora End Of Life 2013-07-03 18:14:47 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-07-31 19:58:37 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.