Bug 837690 - [rhevm-log-collector] log-collector should not prompt for hosts passwords
[rhevm-log-collector] log-collector should not prompt for hosts passwords
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
high Severity unspecified
: rc
: ---
Assigned To: Alon Bar-Lev
Haim
infra
: Reopened, TestBlocker
: 855624 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 15:44 EDT by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 05:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiril Nesenko 2012-07-04 15:44:43 EDT
Description of problem:
log-collector should not promt for hosts passwords

[root@vm-17-67 ~]# rhevm-log-collector collect
Please provide the REST API password for the admin@internal RHEV-M user (CTRL+D to skip):
About to collect information from 7 hypervisors. Continue? (Y/n): y
INFO: Gathering information from selected hypervisors...
INFO: collecting information from white-vdse.eng.lab.tlv.redhat.com
INFO: collecting information from nari11.eng.lab.tlv.redhat.com
INFO: collecting information from nari13.eng.lab.tlv.redhat.com
INFO: collecting information from loki11.eng.lab.tlv.redhat.com
INFO: collecting information from nari12.eng.lab.tlv.redhat.com
INFO: collecting information from white-vdsg.eng.lab.tlv.redhat.com
INFO: collecting information from nott01.eng.lab.tlv.redhat.com
root@nari13.eng.lab.tlv.redhat.com's password: root@white-vdse.eng.lab.tlv.redhat.com's password: root@nari12.eng.lab.tlv.redhat.com's password: root@nari11.eng.lab.tlv.redhat.com's password: root@nott01.eng.lab.tlv.redhat.com's password: root@white-vdsg.eng.lab.tlv.redhat.com's password: root@loki11.eng.lab.tlv.redhat.com's password:



Version-Release number of selected component (if applicable):
rhevm-log-collector-3.1.0-1.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to collect logs
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Keith Robertson 2012-07-09 16:15:08 EDT
The root cause of this problem is that your installer (or your config) hasn't properly set up public/private key authentication between the Engine and the node.  You can easily confirm this with the following SSH command.  If you execute the command and are prompted for a PW then you know that public/private key auth is not working.  

Further, if you are prompted for a PW then you shd know that this is not a LC problem.  It is an installer problem or an engine problem.  The LC will manifest the problem by prompting you for a PW but it is not the source of the problem.

ssh -i /etc/pki/ovirt-engine/keys/engine_id_rsa root@<node here>
Comment 3 Kiril Nesenko 2012-07-11 10:59:49 EDT
Closing the bz. Issue was on my local machine.
Comment 4 Kiril Nesenko 2012-08-02 08:26:07 EDT
I still can reproduce this on si13 build. log-collector promts for passwords and this command doesn't works for me.

[root@vm-17-5 yum.repos.d]# ssh -i /etc/pki/ovirt-engine/keys/engine_id_rsa root@nari11.eng.lab
root@nari11.eng.lab's password:

As Keith said in  Comment 2 , seems like public/private key authentication wasn't set up.
Comment 6 Barak 2012-08-26 09:14:33 EDT
There are 2 ends for above public/private auth isse:
1 - rhevm-setup that produces the host SSH keys
2 - vdsm_bootsrap that configures the host to allow the ssh key-pair access
Comment 7 Alon Bar-Lev 2012-08-27 08:59:04 EDT
Hello Kiril,

How did you install the nari11.eng.lab node?

Can you please check if ~root/.ssh/authorized_keys has anything and/or the correct public key?

Public key can be acquired using:

 # ssh-keygen -y -f /etc/pki/ovirt-engine/keys/engine_id_rsa

Thanks!
Comment 8 Kiril Nesenko 2012-09-04 05:45:48 EDT
Alon, I tested it once again and it works. Key was copied to the host and log-collect does not promts for a password any more.
Closing.
Comment 9 Alon Bar-Lev 2012-09-27 07:26:47 EDT
*** Bug 855624 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.