Bug 837730 - fcoe-target-utils: got python error message when specify non-exist storage-object.
fcoe-target-utils: got python error message when specify non-exist storage-ob...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils (Show other bugs)
6.3
All Linux
medium Severity high
: rc
: ---
Assigned To: Andy Grover
Gris Ge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 22:57 EDT by Gris Ge
Modified: 2013-02-21 05:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:48:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-07-04 22:57:52 EDT
Description of problem:
===
/tcm_fc/20:00...59:12:36/luns> create disk4
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 990, in run_interactive
    self._cli_loop()
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 813, in _cli_loop
    self.run_cmdline(cmdline)
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 934, in run_cmdline
    self._execute_command(path, command, pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 909, in _execute_command
    result = target.execute_command(command, pparams, kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_node.py", line 84, in execute_command
    pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1405, in execute_command
    result = method(*pparams, **kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_target.py", line 786, in ui_command_create
    storage_object = self.get_node(storage_object).rtsnode
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1876, in get_node
    return adjacent_node(path)
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1838, in adjacent_node
    return self.get_child(name)
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1807, in get_child
    % (self.path.rstrip('/'), name))
ValueError: No such path /tcm_fc/20:00:00:1b:21:59:12:36/luns/disk4
======

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb10-5.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Specify non-exist storage object when creating LUN on target/frond-end
2.
3.
  
Actual results:
python failure.

Expected results:
better error output

Additional info:
Comment 1 RHEL Product and Program Management 2012-07-10 03:01:41 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:11:22 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Gris Ge 2013-01-24 22:29:40 EST
VERIFY

No python call trace for non-exist storage object on fcoe-target-utils-2.0rc1.fb16-3.el6.noarch
===
/tcm_fc/20:00...59:12:36/luns> create disk4
Invalid storage object disk4.
===
Comment 6 errata-xmlrpc 2013-02-21 05:48:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0457.html

Note You need to log in before you can comment on or make changes to this bug.