Bug 837785 - rhn_register or bootstrap.sh should perform a 'yum clean' before re-registering a system
rhn_register or bootstrap.sh should perform a 'yum clean' before re-registeri...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks: 471262
  Show dependency treegraph
 
Reported: 2012-07-05 05:11 EDT by riotintoti
Modified: 2013-04-04 11:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-04 11:57:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description riotintoti 2012-07-05 05:11:15 EDT
Description of problem:

We've had an issue when re-registering a system, where new or updated packages in the newly subscribed channels won't install because they're not in the local yum metadata, even after registration.

A 'yum clean' or similar should be added to the bootstrap.sh script or rhn_register process so that yum metadata is rebuilt and updated/new packages in newly subscribed channels are made available to the system.
Comment 1 Clifford Perry 2013-04-04 11:57:18 EDT
This can be done by customer by manually editing the bootstrap script that they use. 

This type of issue of doing a yum clean to force download of new meta-data is independent of registrations. 

I don't see us implementing this globally for all customers. 

Closing deferred. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.