Bug 837812 - [rhevm] - Installer - service ovirt-engine status/stop' commands fail in case of unsuccessful service start
[rhevm] - Installer - service ovirt-engine status/stop' commands fail in case...
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Alex Lourie
David Botzer
Depends On:
  Show dependency treegraph
Reported: 2012-07-05 07:34 EDT by David Botzer
Modified: 2014-01-13 19:03 EST (History)
9 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-04 15:03:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
consoleLOG (63.99 KB, application/octet-stream)
2012-07-05 07:34 EDT, David Botzer
no flags Details
engine-db-install (12.57 KB, application/octet-stream)
2012-07-05 07:36 EDT, David Botzer
no flags Details
engine-setup (95.51 KB, application/octet-stream)
2012-07-05 07:36 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-07-05 07:34:21 EDT
Created attachment 596384 [details]

Description of problem:
Running rhevm-setup and choosing Remote DB option, causes the setup to fails
After which the service ovirt-engine cannot be started

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. I cleaned both Hosts
  rhevm - x.x.x.63 && remote DB server - x.x.x.12 
2. I installed new SI9.1, on the rhevm & remoteDB Hosts
3. I ran rhevm-setup on the REMOTEDB Host, than deleted the engine db & ran rhevm-
   cleanup In order to get the required credencials etc.
4. I ran rhevm-setup on the rhevm Host and selected Remote DB
Actual results:
rhevm-setup Fails And ovirt-engine service cannot be started when installing remoteDB setup

Expected results:
Should succeed installing rhevm & all services should be up & running

Additional info:
Configuring Red Hat Enterprise Virtualization Manager... [ DONE ]
Creating CA...                                           [ DONE ]
Editing JBoss Configuration...                           [ DONE ]
Setting Database Configuration...                        [ DONE ]
Setting Database Security...                             [ DONE ]
Creating Database...                                     [ DONE ]
Updating the Default Data Center Storage Type...         [ DONE ]
Editing Red Hat Enterprise Virtualization Manager Configuration... [ DONE ]
Configuring Firewall (iptables)...                       [ DONE ]
Starting JBoss Service...                             [ ERROR ]
Error: Can't stop the ovirt-engine service
Please check log file /var/log/ovirt-eng
Comment 1 David Botzer 2012-07-05 07:36:07 EDT
Created attachment 596386 [details]
Comment 2 David Botzer 2012-07-05 07:36:31 EDT
Created attachment 596387 [details]
Comment 3 Itamar Heim 2012-07-06 08:31:29 EDT
not sure if this is the intended use/flow, but lets make sure we document how to install with remote db from the remote db server perspective
Comment 4 Moran Goldboim 2012-07-10 09:45:51 EDT
flow seems to be a corner case - lowering priority.
Comment 5 David Botzer 2012-07-11 07:02:50 EDT
This issue is not related to remote setup nor standalone
Changing the headline,

Workaround - delete the /var/run/ovirt-engine.pid
Comment 6 Alex Lourie 2012-07-17 05:13:06 EDT
Fix is posted for review: http://gerrit.ovirt.org/#/c/6364/
Comment 8 David Botzer 2012-07-30 08:13:12 EDT
Fixed, 3.1/si12
setup works fine when remote db is clean (No previous DBs)
Fixed, 3.1/si12

Note You need to log in before you can comment on or make changes to this bug.