Bug 837824 - FTLK backend not working in EL6
FTLK backend not working in EL6
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: octave (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 08:47 EDT by Susi Lehtola
Modified: 2012-09-26 07:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 07:05:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2012-07-05 08:47:52 EDT
Related to the F17 issue with missing buildrequires, I checked the fltk backend in el6. The mesa libraries are in the buildroot, and the fltk backend gets compiled.

However, when I tried to use the backend on a centos6 machine over ssh, I got a segfault:

octave:1> graphics_toolkit("fltk")
octave:2> x=0:.1:2*pi;
octave:3> plot(x,sin(x))
Insufficient GL support
Insufficient GL support

Program received signal SIGSEGV, Segmentation fault.
Fl_Gl_Window::make_current (this=0x2ea34d0) at Fl_Gl_Window.cxx:146
146	    context_ = fl_create_gl_context(this, g);


I'm guessing the GL libraries are too old in EL6, so maybe the fltk support should be disabled in EL6.
Comment 1 Rex Dieter 2012-07-05 09:11:49 EDT
1.  that error comes from fltk indeed
2.  I think it's because your X *server* requires working gl support (ie, the box you're ssh'ing *from*).
Comment 2 Rex Dieter 2012-07-05 09:14:13 EDT
Fwiw, it works for me ok, ssh'ing from an oldish f14 box (with known-working opengl) to a el6 box with octave, and running those commands you typed.
Comment 3 Susi Lehtola 2012-09-26 07:05:43 EDT
Well, as it works for you then closing.

Note You need to log in before you can comment on or make changes to this bug.