Bug 837837 - RFE: Reason palp binaries are installed as palp-${upstream_name} ?
RFE: Reason palp binaries are installed as palp-${upstream_name} ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: palp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 10:26 EDT by Paulo Andrade
Modified: 2012-07-06 13:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 13:56:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-07-05 10:26:03 EDT
To handle this, I will need to make some extra patches to my WIP sagemath package, but would like to know if there is really a requirement to name those this way...

A very good share of current "sage -testall" failures are caused by a message like:

Exception raised:
    [...]
    RuntimeError: Error executing "poly.x -fv" for a polytope sequence!
    Output:
    /bin/sh: poly.x: command not found

as the binary is actually installed as:

$ rpm -ql palp | grep poly.x
/usr/bin/palp-poly.x

I suggest a new package not renaming binaries, and also installing the arxiv.org documentation pdf for palp; not sure how to make automated tests on it tough, due to the way the cgi handles the requests for the file, see the new spec...

Suggested new package:
Spec URL: http://fedorapeople.org/~pcpa/palp.spec
SRPM URL: http://fedorapeople.org/~pcpa/palp-1.1-7.fc18.src.rpm
Comment 1 Conrad Meyer 2012-07-05 21:59:51 EDT
The rationale is here:

https://fedoraproject.org/wiki/Packaging:Conflicts#Potential_Conflicting_Files

There are only 4 binaries:
$ repoquery -ql palp | grep bin
/usr/bin/palp-class.x
/usr/bin/palp-cws.x
/usr/bin/palp-nef.x
/usr/bin/palp-poly.x

The names seem very short / generic, hence the palp- prefix. We could easily update the package to create a libexec directory with symlinks to the binaries, e.g.:

/usr/libexec/palp/class.x -> /usr/bin/palp-class.x
...

This would allow a user (or dependent package) to set PATH="$PATH:/usr/libexec/palp" and use the short binary names.

Do you think the names are unique enough?
Comment 2 Paulo Andrade 2012-07-06 10:37:36 EDT
I think they are unique enough, and would prefer to have less sagemath patches (already have way too much to adapt from sage release to sage release).
But could also add /usr/libexec/palp/ first to $PATH in the sage script.

Also, only people installing sagemath should also install palp anyway, but I still think there should not exist any other package with name conflicts.
Comment 3 Paulo Andrade 2012-07-06 10:42:18 EDT
I just asked for commit access to palp so I can do a more complete help on the issue :-)
Comment 4 Paulo Andrade 2012-07-06 13:56:02 EDT
New rawhide palp package corrects the problem.

Note You need to log in before you can comment on or make changes to this bug.