Bug 837854 - Creating a new product scrambles the Repositories page
Creating a new product scrambles the Repositories page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 11:22 EDT by Og Maciel
Modified: 2014-09-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 10:09:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Notice how the middle panel of the Providers section doesn't show the product associated with the selected Provider (133.83 KB, image/png)
2012-07-05 11:22 EDT, Og Maciel
no flags Details
Here's what the expected look for the web ui should be (158.35 KB, image/png)
2012-07-05 11:34 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-07-05 11:22:29 EDT
Created attachment 596434 [details]
Notice how the middle panel of the Providers section doesn't show the product associated with the selected Provider

Description of problem:

After I created a new product for my newly created product, the Repositories page stopped displaying the content I was looking at. It should have showed my new product and the option to add a repository.

Version-Release number of selected component (if applicable):

* candlepin-0.5.32-1.el6.noarch
* candlepin-tomcat6-0.5.32-1.el6.noarch
* katello-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-all-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.6-1.el6.noarch
* katello-cli-0.2.42-1.git.26.3d87775.el6_3.noarch
* katello-cli-common-0.2.42-1.git.26.3d87775.el6_3.noarch
* katello-common-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-configure-0.2.29-1.git.0.7330d57.el6_3.noarch
* katello-glue-candlepin-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-glue-foreman-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-glue-pulp-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.2.6-1.el6.noarch
* pulp-1.1.10-1.el6.noarch
* pulp-common-1.1.10-1.el6.noarch
* pulp-selinux-server-1.1.10-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. Create a new Organization with a single Environment
2. Switch to the new Organization
3. Click the Repositories tab
4. Add a new Custom Provider
5. Add a new Product to the new Provider
  
Actual results:

The (attached) screenshot shows how the section where the new product should be displayed doesn't shows the Product I created for my Katello Provider

Expected results:

It should show me my newly created Product and the option to add Repositories

Additional info:
Comment 1 Og Maciel 2012-07-05 11:34:57 EDT
Created attachment 596437 [details]
Here's what the expected look for the web ui should be

Here's what the expected look for the web ui should be
Comment 3 Og Maciel 2012-09-25 21:15:19 EDT
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-9.el6cf.noarch
* katello-all-1.1.12-9.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-5.el6cf.noarch
* katello-cli-common-1.1.8-5.el6cf.noarch
* katello-common-1.1.12-9.el6cf.noarch
* katello-configure-1.1.9-4.el6cf.noarch
* katello-glue-candlepin-1.1.12-9.el6cf.noarch
* katello-glue-pulp-1.1.12-9.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 4 James Laska 2012-12-12 10:09:07 EST
CloudForms-1.1 shipped with katello-1.1.12-22.el6cf, candlepin-0.7.8.1-1.el6cf and pulp-1.1.14-1.el6cf

Marking this bug CLOSED CURRENTRELEASE.  Please reopen if the problem has not been addressed in the 1.1 product.
Comment 5 Mike McCune 2013-08-16 14:17:51 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.