Bug 837866 - RFE: katello-upgrade man page should provide info to stop and start all necessary services
RFE: katello-upgrade man page should provide info to stop and start all neces...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 12:08 EDT by Og Maciel
Modified: 2014-09-18 13:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:57:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-07-05 12:08:24 EDT
Description of problem:

When upgrading katello, the katello-upgrade script should handle stopping and starting all necessary services.

Currently I am doing:

* for i in katello katello-jobs pulp-server tomcat6 elasticsearch qpidd; do service $i stop; done
* katello-upgrade
* for i in katello katello-jobs pulp-server tomcat6 elasticsearch qpidd; do service $i start; done
 
Version-Release number of selected component (if applicable):

* candlepin-0.5.32-1.el6.noarch
* candlepin-tomcat6-0.5.32-1.el6.noarch
* katello-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-all-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.6-1.el6.noarch
* katello-cli-0.2.42-1.git.26.3d87775.el6_3.noarch
* katello-cli-common-0.2.42-1.git.26.3d87775.el6_3.noarch
* katello-common-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-configure-0.2.29-1.git.0.7330d57.el6_3.noarch
* katello-glue-candlepin-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-glue-foreman-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-glue-pulp-0.2.44-1.git.53.38a8afc.el6_3.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.2.6-1.el6.noarch
* pulp-1.1.10-1.el6.noarch
* pulp-common-1.1.10-1.el6.noarch
* pulp-selinux-server-1.1.10-1.el6.noarch
Comment 2 Lukas Zapletal 2012-07-23 10:58:03 EDT
Starting and stopping services is very fragile thing on production systems. The Satellite/Spacewalk approach is to ask to stop services manually and we are going to follow the same way. Additionally, there should be new katello-service command in master that only requires one simple command to stop everything.

I would recomend NOFIX for this one.
Comment 3 Lukas Zapletal 2012-07-23 11:00:36 EDT
We should definitely document this how to stop and start services during upgrade. Changing the topic - doco only.
Comment 5 Lukas Zapletal 2012-07-24 06:30:32 EDT
Well, it seems there is already an ongoing effort very close to be merged: https://github.com/Katello/katello/pull/331 I guess once it is merged this can be closed.
Comment 6 Mike McCune 2012-10-24 11:08:20 EDT
The functionality is now there to start and stop the services with katello-upgrade but the man page is missing this info:

katello-upgrade(1)             Katello Reference            katello-upgrade(1)

NAME
       katello-upgrade - Katello upgrade tool

....
COMMAND LINE PARAMETERS
       --assumeyes, -y
           Answer yes to all prompts.

       --dry-run, -d
           Print the upgrade steps without doing anything.

       --skip-default, -s
           Skips the default upgrade steps.

       --log=<LOG_FILE>
           Log file for the script output. Defaults to /var/log/katello/katello_upgrade.log.  Set to
           ’stdout’ to print the output directly on the console.

       --help, -h
           Display short summary of all options.

So, this bug should be used to address the missing man page information.
Comment 9 Dan Macpherson 2013-09-25 01:06:30 EDT
NEEDINFOing mmccune -- Is this still relevant for Sat 6.0?
Comment 10 sachua 2013-11-26 21:13:02 EST
Reassigning bug because this is a man page issue/upgrade fix.
Comment 13 Mike McCune 2014-03-18 13:57:47 EDT
CLOSING as we do not currently have any upgrade routines as katello-upgrade is gone and we are now part of foreman.

when we build upgrade tooling for 6.0.5 we will take this into consideration.

Note You need to log in before you can comment on or make changes to this bug.