Bug 837876 - JON Agent RPM Errata Failure(s): Shell syntax, XML Validation
JON Agent RPM Errata Failure(s): Shell syntax, XML Validation
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.0
Unspecified Unspecified
high Severity high
: ---
: JON 3.1.1
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: 837381
  Show dependency treegraph
 
Reported: 2012-07-05 12:40 EDT by Mike Foley
Modified: 2012-07-09 10:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 10:37:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
errata failure for xml validation (162.70 KB, image/png)
2012-07-05 14:49 EDT, Mike Foley
no flags Details
errata failure for shell syntax (30.11 KB, image/png)
2012-07-05 14:52 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2012-07-05 12:40:00 EDT
https://errata.devel.redhat.com/rpmdiff/show/62412?result_id=1141625


Document the waiver of these 2 tests, or fix.
Comment 1 Mike Foley 2012-07-05 14:49:31 EDT
Created attachment 596475 [details]
errata failure for xml validation
Comment 2 Mike Foley 2012-07-05 14:52:20 EDT
Created attachment 596477 [details]
errata failure for shell syntax
Comment 3 Charles Crouch 2012-07-05 15:22:23 EDT
(In reply to comment #1)
> Created attachment 596475 [details]
> errata failure for xml validation

These are errors for the JON server so are not related to the JON agent.
Comment 4 Stefan Negrea 2012-07-06 17:22:44 EDT
The failure from comment #2 should be waived because the problem was detected in the source RPM and not in the binary RPM. The two files (jon-agent.init and jon-agent-ec2.init) are just templates processed by Brew to create init script. The two scripts are bundled with the binary RPMs and the rpmdiff tool reported no errors there.
Comment 5 Mike Foley 2012-07-09 10:37:53 EDT
documented errata waiver

Note You need to log in before you can comment on or make changes to this bug.