Bug 837937 - Product subscription details do not get refreshed
Product subscription details do not get refreshed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-05 17:01 EDT by J.C. Molet
Modified: 2013-01-07 22:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no refresh (413.83 KB, image/png)
2012-07-05 17:02 EDT, J.C. Molet
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0033 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-01-08 03:38:27 EST

  None (edit)
Description J.C. Molet 2012-07-05 17:01:15 EDT
Description of problem:
When browsing through the My Installed Product List in the gui, I noticed that the details values do not get refreshed if the product's .pem file does not have a value set for that detail.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.8-1.git.7.404dcd1.el5

How reproducible:
always

Steps to Reproduce:
1. Install/copy all the TESTDATA product pems from candlepin to /etc/pki/product/
2. Fire up subscription-manager-gui
3. click on any product that has a Arch set in its .pem (eg: Clustering Bits)
4. click on any product that does not have an arch set in its .pem (eg: Flexible Hypervisor(Premium Architectures-15-pack))
  
Actual results:
The Arch value for the product selected in step 3 is displayed for the product in step 4.

Expected results:
When selecting the product in step 4, the value is cleared.

Additional info:
I've shown this is happening for the arch field, but it turns out this happens FOR ALL of the details.  Try subscribing to "Awesome OS Server Bundled (2 Sockets, Standard Support)" after step 2 and try steps 3 and 4 using the examples.
Comment 1 J.C. Molet 2012-07-05 17:02:30 EDT
Created attachment 596502 [details]
no refresh

See attached screenshot.
Comment 2 RHEL Product and Program Management 2012-07-05 17:07:04 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 William Poteat 2012-08-07 11:35:32 EDT
Tested against subscription-manager-1.0.12-1.git.32.6dc35a8.fc16.x86_64 using a product cert with [empty string] for the arch. It does not carry over the previous value.
Comment 5 J.C. Molet 2012-09-20 08:21:59 EDT
This is tested by automation in the check_version_arch test.

http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/Entitlement/job/jmolet-scratch/808/TestNG_Report/

Example run can be seen here, and that all tests for every product in the test data passes.  This run was tested against:

subscription-manager-gui-1.0.19-1.git.0.7c79e3b.el5

Marking Verified.
Comment 6 J.C. Molet 2012-09-20 08:41:04 EDT
Also verified this manually on brew build:


  subscription-manager-gui.x86_64 0:1.0.18-1.el5
Comment 8 errata-xmlrpc 2013-01-07 22:56:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.