Bug 837949 - watchdog in FC17 very old
watchdog in FC17 very old
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: watchdog (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 838055
  Show dependency treegraph
 
Reported: 2012-07-05 17:58 EDT by Dan Hollis
Modified: 2012-07-17 13:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 838055 (view as bug list)
Environment:
Last Closed: 2012-07-17 13:23:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2012-07-05 17:58:10 EDT
Description of problem:
watchdog 5.9 (2010) in FC17 is very old, and has a number of crticial bugs such as the inability to reliably ping a target. it should be updated to 5.12 (2012).

Version-Release number of selected component (if applicable):
watchdog-5.9-3.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.put a ping <ipaddress> option in watchdog.conf
2.start up watchdog
3.

Actual results:
Jul  5 04:29:55 ns1 watchdog[1044]: starting daemon (5.9):
Jul  5 04:29:55 ns1 watchdog[1044]: int=1s realtime=yes sync=no soft=no mla=0 mem=0
Jul  5 04:29:55 ns1 watchdog[1044]: ping: 192.168.0.1
Jul  5 04:29:55 ns1 watchdog[1044]: file: no file to check
Jul  5 04:29:55 ns1 watchdog[1044]: pidfile: no server process to check
Jul  5 04:29:55 ns1 watchdog[1044]: interface: no interface to check
Jul  5 04:29:55 ns1 watchdog[1044]: test=none(0) repair=none(0) alive=none heartbeat=none temp=none to=root no_act=yes
Jul  5 04:29:56 ns1 watchdog[1044]: no response from ping (target: 192.168.0.1)
Jul  5 04:29:56 ns1 watchdog[1020]: still alive after 8 interval(s)
Jul  5 04:29:56 ns1 watchdog[1020]: no response from ping (target: 192.168.0.1)
[...]
Jul  5 04:30:21 ns1 watchdog[315]: shutting down the system because of error 101

Expected results:
Jul  5 04:32:16 ns1 watchdog[2697]: starting daemon (5.12):
Jul  5 04:32:16 ns1 watchdog[2697]: int=1s realtime=yes sync=no soft=no mla=0 mem=0
Jul  5 04:32:16 ns1 watchdog[2697]: ping: 192.168.0.1
Jul  5 04:32:16 ns1 watchdog[2697]: file: no file to check
Jul  5 04:32:16 ns1 watchdog[2697]: pidfile: no server process to check
Jul  5 04:32:16 ns1 watchdog[2697]: interface: no interface to check
Jul  5 04:32:16 ns1 watchdog[2697]: test=none(0) repair=none(0) alive=none heartbeat=none temp=none to=root no_act=yes
Jul  5 04:32:16 ns1 watchdog[2697]: ping select timeout = 1 seconds and 0 useconds
Jul  5 04:32:16 ns1 watchdog[2697]: got answer from target 192.168.0.1
Jul  5 04:32:16 ns1 watchdog[2697]: still alive after 1 interval(s)

Additional info:
Comment 1 Richard W.M. Jones 2012-07-05 18:04:06 EDT
Agreed.  Since it's rather late now I'll try to push
an updated package tomorrow.
Comment 2 Fedora Update System 2012-07-06 06:24:24 EDT
watchdog-5.12-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/watchdog-5.12-1.fc17
Comment 3 Fedora Update System 2012-07-06 17:27:58 EDT
Package watchdog-5.12-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing watchdog-5.12-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10347/watchdog-5.12-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-07-17 13:23:17 EDT
watchdog-5.12-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.