This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 837972 - Io-language-20110912-1.fc18 is FTBFS on ARM
Io-language-20110912-1.fc18 is FTBFS on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Io-language (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-07-05 19:50 EDT by Peter Robinson
Modified: 2012-10-09 10:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 10:30:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Jon Ciesla 2012-07-24 10:19:00 EDT
End of build log:

Scanning dependencies of target coroutine
[ 11%] Building C object libs/coroutine/CMakeFiles/coroutine.dir/source/context.c.o
/builddir/build/BUILD/stevedekorte-io-23afbcc/libs/coroutine/source/context.c: In function 'makecontext':
/builddir/build/BUILD/stevedekorte-io-23afbcc/libs/coroutine/source/context.c:104:18: error: 'mcontext_t' has no member named 'gregs'
/builddir/build/BUILD/stevedekorte-io-23afbcc/libs/coroutine/source/context.c:106:17: error: 'mcontext_t' has no member named 'gregs'
/builddir/build/BUILD/stevedekorte-io-23afbcc/libs/coroutine/source/context.c:107:17: error: 'mcontext_t' has no member named 'gregs'
make[2]: *** [libs/coroutine/CMakeFiles/coroutine.dir/source/context.c.o] Error 1
make[1]: *** [libs/coroutine/CMakeFiles/coroutine.dir/all] Error 2

Appears to be due to lack of ARM support.  That dir has a 386-ucontext.h and an amd64-ucontext.h, and that's it.  taskimpl.h checks that __arm__ is defined, but 
the actions taken don't seem to be sufficient.  A corresponding arm-ucontext.h is likely needed.  Do thing this is something someone in the ARM team could create, or that I could create, given an ARM VM?  Upstream might not have access to an ARM system to create this, but I suspect would happily accept patches.
Comment 2 Peter Robinson 2012-07-24 10:25:50 EDT
> Appears to be due to lack of ARM support.  That dir has a 386-ucontext.h and
> an amd64-ucontext.h, and that's it.  taskimpl.h checks that __arm__ is
> defined, but 
> the actions taken don't seem to be sufficient.  A corresponding
> arm-ucontext.h is likely needed.  Do thing this is something someone in the
> ARM team could create, or that I could create, given an ARM VM?  Upstream
> might not have access to an ARM system to create this, but I suspect would
> happily accept patches.

It's possible we could but I usually first check if Debian or Ubuntu have done it already. Sometimes there's patch sets in the debian packages
Comment 3 Jon Ciesla 2012-07-24 10:33:52 EDT
I don't see it in Debian or Ubuntu, if I'm searching properly.  Google only gives me old inquiries and this BZ. :)
Comment 4 Jon Ciesla 2012-09-17 12:41:31 EDT
https://github.com/stevedekorte/io/issues/226
Comment 5 Jon Ciesla 2012-09-18 11:30:31 EDT
Committed fix to rawhide, building for primary, posted patch to upstream bug.
Comment 6 Fedora Update System 2012-09-24 08:24:28 EDT
Io-language-20110912-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/Io-language-20110912-6.fc18
Comment 7 Fedora Update System 2012-09-24 16:01:38 EDT
Package Io-language-20110912-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Io-language-20110912-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14666/Io-language-20110912-6.fc18
then log in and leave karma (feedback).
Comment 8 Peter Robinson 2012-10-09 10:30:45 EDT
Fixed and pushed to stable

Note You need to log in before you can comment on or make changes to this bug.