Bug 838005 - [whql][netkvm] Job of "NDISTest6.5-[1 Machine]-OffloadParity" failed on HCK on win8-64 and win2012
Summary: [whql][netkvm] Job of "NDISTest6.5-[1 Machine]-OffloadParity" failed on HCK o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-06 05:54 UTC by dawu
Modified: 2014-07-11 06:39 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Offloads for IPv6 are implemented. Reason: Enforced by WHQL requirements. Result (if any):
Clone Of:
Environment:
Last Closed: 2013-02-21 10:39:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0441 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-02-20 20:48:13 UTC

Description dawu 2012-07-06 05:54:09 UTC
Created attachment 596574 [details]
win8AndWin2012_OffloadParity.wtl

Description of problem:
Job 1105 of "NDISTest6.5-[1 Machine]-OffloadParity" failed on HCK on win8-64 and win2012

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29

How reproducible:
always

Steps to Reproduce:
1. Start guest with CLI:

   /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win8-64-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:51:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:10:1a:16:51:03,bus=pci.0,addr=0x6 -uuid d3ee35eb-2278-48f4-b71c-85112b0a79ef -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -bios /usr/share/seabios/bios-pm.bin -monitor stdio

2. Run task "Run NDISTest Client"
  
Actual results:
Job failed on win8-64 and win2012 on HCK, please refer to the HCK logs from attached "win8AndWin2012_OffloadParity.wtl" for details

Expected results:
Job should pass without any error

Additional info:

Comment 3 Mike Cao 2012-08-24 02:59:41 UTC
No netkvm for win8 guests in prewhql build  , change status to post

Comment 4 Mike Cao 2012-10-12 08:08:52 UTC
mdeng

pls run netkvm whql test on latest virtio-win prewhql build to verify this bug 

Thanks,
Mike

Comment 6 Min Deng 2012-10-18 04:59:27 UTC
Verified the bug on build 39 
For steps,please refer to comment 0
Actual&Expected results,
The job pass smoothly on win8 and win2012 guests.so the issue should be fixed now,thanks

Comment 7 Mike Cao 2012-10-18 05:06:18 UTC
Based on comment #6 ,move status to VERIFIED.

Mike

Comment 8 errata-xmlrpc 2013-02-21 10:39:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html


Note You need to log in before you can comment on or make changes to this bug.