Bug 838039 - Integrity constraint during installation
Integrity constraint during installation
Status: CLOSED DEFERRED
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
1.7
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-07-06 03:53 EDT by Gerhardus Geldenhuis
Modified: 2012-11-01 12:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 15:03:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerhardus Geldenhuis 2012-07-06 03:53:02 EDT
OS: Oracle Linux 5.8 (with Red Hat kernel, I want to emphasize that it is not my choice of OS)
Spacewalk:1.7
DB: Oracle, external 11.2.0.3.0 - 64bit
Client: SQL*Plus: Release 11.2.0.2.0

The spacewalk installation is on a beefy virtual machine.

I go through the installation instructions and get up to the spacewalk-setup --disconnected step. After it connects to the database it starts creating and the taskbar seems to be almost reaching a 100% but then fails:


The log entry is:
...
1 row created.
1 row created.
Commit complete.
insert into rhnPackageSyncBlacklist (package_name_id)
*
ERROR at line 1:
ORA-02291: integrity constraint (SPACEWALKDBUSER.RHN_PACKAGESYNCBL_PNID_FK) violated - parent key not found

Is this a bug or some restriction on the database? I have little to no control over the DB but can relay information to the DBA if required.
Comment 1 Jan Pazdziora 2012-07-11 15:03:06 EDT
This seems like some esoteric issue with some Oracle RDBMS 11g versions. Please contact your Oracle support about the behaviour of autonomous transactions. Also see

https://www.redhat.com/archives/spacewalk-list/2011-May/msg00024.html

Note You need to log in before you can comment on or make changes to this bug.