This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 838068 - gcl is FTBFS on ARM
gcl is FTBFS on ARM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gcl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-07-06 07:50 EDT by Peter Robinson
Modified: 2013-02-01 11:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 11:58:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-07-06 07:50:53 EDT
gcl fails to build on ARM

http://arm.koji.fedoraproject.org/taskinfo?taskID=942263
Comment 1 Jon Ciesla 2012-09-22 20:06:11 EDT
I couldn't build this at first because ImageMagick failed to install with a cpio error.  I rebuilt that locally, and gcl built fine.
Comment 2 Peter Robinson 2012-09-24 06:29:34 EDT
Not in koji it doesn't

http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=2100
Comment 3 Jon Ciesla 2012-09-24 09:23:38 EDT
Hmm.  I was using the f9 ImageMagick on f17.  Let me try the f18 version.
Comment 4 Jon Ciesla 2012-09-24 12:37:27 EDT
I meant f19 of course.  Works for me with the f18 as well, all on f17.  Hmm.  Must be something else breaking it, though the f17 ImageMagick package needs a rebuild.  What's the best way to set up f18 on a Pi?
Comment 5 Jerry James 2012-09-24 23:09:17 EDT
Argh, sorry, this bug was initially filed when I was in a period where $DAYJOB was $DAYANDNIGHTJOB, and then it fell off my radar.  The build logs are long gone.  If anybody tries another build and it fails again, please point me to the new build logs.  In the meantime, I've set up an F-18 ARM VM and will soon, very soon, actually boot the sucker up to see what it can do.
Comment 6 Jon Ciesla 2012-09-25 08:17:51 EDT
The logs in #2 are there still.
Comment 7 Jerry James 2012-09-25 10:37:50 EDT
D'oh!  Okay, it looks like the problem is that the ARM platform has grown a new type of reloc that the existing code doesn't know about.  I'll try to figure out what it is and how to handle it.
Comment 8 Fedora Update System 2013-01-21 22:54:08 EST
gcl-2.6.8-0.13.20130121cvs.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gcl-2.6.8-0.13.20130121cvs.fc18
Comment 9 Fedora Update System 2013-01-23 11:07:19 EST
Package gcl-2.6.8-0.13.20130121cvs.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcl-2.6.8-0.13.20130121cvs.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1315/gcl-2.6.8-0.13.20130121cvs.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-02-01 11:58:53 EST
gcl-2.6.8-0.13.20130121cvs.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.