Bug 838071 - dhclient is not started initializing interfaces
dhclient is not started initializing interfaces
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 08:01 EDT by Thomas Schweikle
Modified: 2015-02-17 09:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 09:20:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2012-07-06 08:01:24 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.10 Chromium/18.0.1025.168 Chrome/18.0.1025.168 Safari/535.19
Build Identifier: 

dhclient is not started initializing interfaces in tune all network services are not started, because the interface isn't ready (does not receive an address).

Reproducible: Always

Steps to Reproduce:
1. Install fedora rawhide
2. boot
3.
Actual Results:  
no network interface except lo is configured with an address.

Expected Results:  
dhclient configuring available network interfaces

dhclient isn't executed by dracut/systemd. In tune none of the configured network interfaces receives an address and no network services are started. Login in on console and executing "dhclient eth0", "systemctl start sshd.service" does what is expected to be done automatically: assign an address and start sshd. Afterwards you may log in remotely.
Comment 1 Fedora End Of Life 2013-04-03 11:26:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 John Horne 2013-08-27 16:02:45 EDT
Just updated my PC from F17 to F19 with a fresh install.

I am seeing what seems to be the same problem with my wireless network.
wpa_supplicant starts okay and associates the wireless adapter with the router, but when the system is fully up the interface has no IP address assigned to it. It seems that dhclient is not started at all (it is not seen in 'ps auxww').

If I run 'ifdown wlan0 && ifup wlan0' then the interface comes up with an IP address. dhclient is now running.

I don't use NetworkManager, but use the same wpa_suppliant and ifcfg configuration files that worked fine with F17.
Comment 3 Jiri Popelka 2013-08-28 04:41:19 EDT
(In reply to John Horne from comment #2)
> If I run 'ifdown wlan0 && ifup wlan0' then the interface comes up with an IP
> address. dhclient is now running.
> I don't use NetworkManager...

Then you need the legacy network service enabled.
What does 'systemctl is-enabled network.service' show ?
Comment 4 John Horne 2013-08-28 09:26:33 EDT
Yup, figured that out late last night when trying to find out what actually executed 'ifup'. Once I had enabled the 'network' to start, the network interfaces came up with no problems upon reboot.

For completeness the 'systemctl' output (with legacy network enabled) is:

=====
network.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig network --level=5
enabled
=====


Thanks for your help, and sorry for the noise in this bug report.


John.
Comment 5 Fedora End Of Life 2015-01-09 12:14:31 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 09:20:05 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.