Bug 838086 - [Intel Fedora18 FEAT] Include LED Control Utilities in Fedora 18
[Intel Fedora18 FEAT] Include LED Control Utilities in Fedora 18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ledmon (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
https://sourceforge.net/projects/ledmon/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 09:09 EDT by Lukasz Dorau
Modified: 2012-07-25 03:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: ledmon-0.40-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 02:04:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukasz Dorau 2012-07-06 09:09:21 EDT
1.	Feature Name: 
Include LED Control Utilities in Fedora 18

2.	Description: 
Feature includes ledctl application and ledmon daemon.

The ledctl is user space application design to control LEDs associated with each slot in an enclosure or a drive bay. There are two types of system: 2-LEDs system (Activity LED, Status LED) and 3-LEDs system (Activity LED, Locate LED, Fail LED). User must have root privileges to use this application.
The ledctl application uses SGPIO and SES-2 protocol to control LEDs. 
The program implements IBPI patterns from SFF-8489 specification for SGPIO. 

The ledmon application is daemon program to monitor a state of software RAID device (md only) or a state of block device. The state is visualizing on LEDs associated with each slot in an enclosure or a drive bay. There are two types of system: 2-LEDs system (Activity LED, Status LED) and 3-LEDs system (Activity LED, Locate LED, Fail LED). This application has the highest priority when accessing the LEDs.

The ledctl application and ledmon daemon are part of Intel(R) LED Control Utilities.

3.	Business Justification: 
     a. Why is this feature needed?
     Enable feature parity with the latest Windows IMSM stack for Linux customers. 
Enable LED management for software RAID solutions. 

     b. What hardware does this enable?
     none

     c. Forecast, impact on revenue?
     none 

     d. Any configuration info?
     none

     e. Are there other dependencies (drivers).
     AHCI, SAS drivers. Modules: ENCLOSURE and SES compiled into kernel.

4.	Feature Details:
a.	Architectures:
         32-bit x86 
         64-bit Intel EM64T
         64-bit Itanium2

b.	Bugzilla Dependencies:
mdadm with Intel Matrix extensions

c.	Drivers or hardware dependencies:
Any RAID supporting Intel HW platforms can be used, e.g. ICH9, ICH10, Ibexpeak, Patsburg when available.
SGPIO output.

d.	Upstream acceptance information:
Under development. Will be delivered on this bugzilla when will be finish.

e.	External links:
         None

f.	Severity (U,H,M,L):
         Medium

g.	Target Release Date:

5.	Primary contact at Red Hat, email, phone (chat)
     John Villalovos
     jvillalo@redhat.com

6.	Primary contact at Partner, email, phone (chat)
     Gabbert, Keve A, +1 503 264 7597
     keve.a.gabbert@intel.com

The current version of ledmon and ledctl is available at SourceForge.net:
https://sourceforge.net/projects/ledmon/

We recommend it for Fedora 18.
Comment 1 Maciej Naruszewicz 2012-07-24 10:35:51 EDT
Recommended version of ledmon for Fedora 18 will be released in WW32 on SourceForge.
Comment 2 Jan Synacek 2012-07-25 02:04:27 EDT
Ledmon is already included in Fedora 18. I understand this bugzilla as a request to update the package to the new upstream version.

Fixed:
http://lists.fedoraproject.org/pipermail/scm-commits/2012-July/832931.html
Comment 3 Maciej Naruszewicz 2012-07-25 02:59:44 EDT
(In reply to comment #2)
> Ledmon is already included in Fedora 18. I understand this bugzilla as a
> request to update the package to the new upstream version.
> 

Precisely - however, due to tests the recommended version of ledmon for Fedora 18 isn't in the upstream yet. Should we put a comment here as soon as it is placed in SourceForge, or file another bugzilla requesting to update ledmon ?

> Fixed:
> http://lists.fedoraproject.org/pipermail/scm-commits/2012-July/832931.html

Thanks.
Comment 4 Jan Synacek 2012-07-25 03:09:00 EDT
Please, file a new update request bug as soon as the wanted version of ledmon is available.

Note You need to log in before you can comment on or make changes to this bug.