Bug 838099 - Update python-sqlalchemy0.7 to 0.7.4 or later
Update python-sqlalchemy0.7 to 0.7.4 or later
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-sqlalchemy0.7 (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 10:31 EDT by Ralph Bean
Modified: 2012-09-16 14:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 892384 (view as bug list)
Environment:
Last Closed: 2012-09-16 14:28:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Bean 2012-07-06 10:31:14 EDT
Alembic fails to pass its unit tests against sqlalchemy-0.7.3
http://kojipkgs.fedoraproject.org/work/tasks/2144/4222144/build.log

The author of sqlalchemy (zzzeek) thinks that an update to sqlalchemy-0.7.4 or later will fix the issue.  https://twitter.com/zzzeek/status/221247697280180224

This is needed for python-alembic to build against epel6.
https://bugzilla.redhat.com/show_bug.cgi?id=837988
Comment 1 Toshio Ernie Kuratomi 2012-08-30 12:27:10 EDT
pbrady, stevetraylen: any input here?  If this sounds okay to you but you're busy, I can update.  As I've been upgrading the main package (in Fedora, not in EPEL) the changelogs haven't shown any incompatible changes in the 0.7.x series.  0.7.8 is the latest.
Comment 2 Pádraig Brady 2012-08-30 20:04:10 EDT
Thanks for the ping.
0.7.4 should be fine.

0.7.8 might be OK. That's the version used on Fedora 17.
I also scanned the changelog and noticed no obvious compat issues.
Lots of bugs fixed, and no new release since June.

OK I'll update to 0.7.8 so.
Comment 3 Fedora Update System 2012-08-30 21:03:45 EDT
python-sqlalchemy0.7-0.7.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-sqlalchemy0.7-0.7.8-1.el6
Comment 4 Fedora Update System 2012-08-31 14:31:49 EDT
Package python-sqlalchemy0.7-0.7.8-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-sqlalchemy0.7-0.7.8-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-12777/python-sqlalchemy0.7-0.7.8-1.el6
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-16 14:28:43 EDT
python-sqlalchemy0.7-0.7.8-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.