Bug 838105 - dracut creates initramfs.img with only 1117 bytes
dracut creates initramfs.img with only 1117 bytes
Status: CLOSED DUPLICATE of bug 838367
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 11:03 EDT by Mamoru TASAKA
Modified: 2012-07-09 02:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 02:31:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from dracut (1.30 MB, text/plain)
2012-07-06 11:03 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2012-07-06 11:03:37 EDT
Created attachment 596659 [details]
output from dracut

Description of problem:
With dracut -f with uname -r = 3.4.4-3.fc17.i686 (now using F17 kernel), latest dracut produces only 1117 bytes initramfs.img

Version-Release number of selected component (if applicable):
kernel-3.4.4-3.fc17.i686
systemd-186-1.fc18.i686
dracut-020-51.git20120706.fc18.i686

How reproducible:
100%

Steps to Reproduce:
1. dracut -f --debug
2.
3.
  
Actual results:
See attached.
Comment 1 Peter Lemenkov 2012-07-08 03:38:59 EDT
I can confirm this. Here is a list of what's inside initramfs:

sulaco ~: lsinitrd /boot/initramfs-3.5.0-0.rc4.git4.1.fc18.ppc.img
/boot/initramfs-3.5.0-0.rc4.git4.1.fc18.ppc.img: 4,0K
========================================================================
========================================================================
drwxr-xr-x   8 root     root            0 Jul  8 11:31 .
-rwxr-xr-x   1 root     root         1495 Jul  8 11:30 shutdown
lrwxrwxrwx   1 root     root           24 Jul  8 11:30 init -> /usr/lib/systemd/systemd
drwxr-xr-x   5 root     root            0 Jul  8 11:30 run
drwxr-xr-x   3 root     root            0 Jul  8 11:30 run/udev
drwxr-xr-x   2 root     root            0 Jul  8 11:30 run/udev/rules.d
drwxr-xr-x   2 root     root            0 Jul  8 11:30 run/initramfs
drwxr-xr-x   2 root     root            0 Jul  8 11:30 run/lock
drwxr-xr-x   2 root     root            0 Jul  8 11:30 root
drwxr-xr-x   2 root     root            0 Jul  8 11:30 sysroot
drwxr-xr-x   2 root     root            0 Jul  8 11:30 sys
drwxr-xr-x   2 root     root            0 Jul  8 11:30 proc
drwxr-xr-x   2 root     root            0 Jul  8 11:30 dev
crw-r--r--   1 root     root       5,   1 Jul  8 11:30 dev/console
crw-r--r--   1 root     root       1,  11 Jul  8 11:30 dev/kmsg
crw-r--r--   1 root     root       1,   3 Jul  8 11:30 dev/null
lrwxrwxrwx   1 root     root            4 Jul  8 11:30 var -> /var
lrwxrwxrwx   1 root     root            4 Jul  8 11:30 usr -> /usr
lrwxrwxrwx   1 root     root            4 Jul  8 11:30 tmp -> /tmp
lrwxrwxrwx   1 root     root            5 Jul  8 11:30 sbin -> /sbin
lrwxrwxrwx   1 root     root            4 Jul  8 11:30 lib -> /lib
lrwxrwxrwx   1 root     root            4 Jul  8 11:30 etc -> /etc
lrwxrwxrwx   1 root     root            4 Jul  8 11:30 bin -> /bin
========================================================================
sulaco ~:
Comment 2 Richard W.M. Jones 2012-07-08 12:48:17 EDT
I can confirm this too.  Here's the --verbose output of
dracut.

/usr/sbin/dracut: line 546: unset: prefix: cannot unset: readonly variable
I: *** Including module: i18n ***
cp: `/usr/lib/kbd/consolefonts' and `/var/tmp/initramfs.20389H//usr/lib/kbd/consolefonts' are the same file
cp: `/usr/lib/kbd/consoletrans' and `/var/tmp/initramfs.20389H//usr/lib/kbd/consoletrans' are the same file
cp: `/usr/lib/kbd/keymaps' and `/var/tmp/initramfs.20389H//usr/lib/kbd/keymaps' are the same file
cp: `/usr/lib/kbd/unimaps' and `/var/tmp/initramfs.20389H//usr/lib/kbd/unimaps' are the same file
I: *** Including module: plymouth ***
I: *** Including module: btrfs ***
I: *** Including module: crypt ***
I: *** Including module: dm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: dmraid ***
I: *** Including module: kernel-modules ***
I: Omitting driver nfs_acl
I: Omitting driver nfs
I: Omitting driver nfs_layout_nfsv41_files
I: Omitting driver objlayoutdriver
I: Omitting driver blocklayoutdriver
I: Omitting driver nfsd
I: Omitting driver lockd
I: *** Including module: lvm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: mdraid ***
I: *** Including module: multipath ***
I: Skipping udev rule: 40-multipath.rules
I: *** Including module: resume ***
I: *** Including module: rootfs-block ***
I: *** Including module: terminfo ***
cp: `/usr/share/terminfo' and `/var/tmp/initramfs.20389H//usr/share/terminfo' are the same file
I: *** Including module: udev-rules ***
I: *** Including module: virtfs ***
I: *** Including module: biosdevname ***
I: *** Including module: systemd ***
egrep: input file '/etc/group' is also the output
I: *** Including module: usrmount ***
I: *** Including module: base ***
root:x:0:0:root:/root:/bin/bash
egrep: input file '/etc/passwd' is also the output
I: *** Including module: fs-lib ***
I: *** Including module: shutdown ***
I: *** Including modules done ***
I: *** Installing kernel module dependencies and firmware ***
I: *** Installing kernel module dependencies and firmware done ***
I: *** Resolving executable dependencies ***
I: *** Resolving executable dependencies done***
ldconfig: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf: Too many levels of symbolic links
ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Too many levels of symbolic links
E: ldconfig exited ungracefully
I: *** hardlinking files ***
I: *** hardlinking files done ***
I: *** Creating image file ***
I: *** Creating image file done ***
I: Wrote /boot/initramfs-3.5.0-0.rc5.git3.1.fc18.x86_64.img:
I: -rw-r--r--. 1 root root 1129 Jul  8 18:38 /boot/initramfs-3.5.0-0.rc5.git3.1.fc18.x86_64.img

------

The ldconfig error looks completely bogus to me.  No symlinks
in sight:

# ls -l /etc/ld.so*
-rw-r--r--. 1 root root 95423 Jul  8 18:42 /etc/ld.so.cache
-rw-r--r--. 1 root root    28 Jul  6 06:42 /etc/ld.so.conf

/etc/ld.so.conf.d:
total 44
-rw-r--r--. 1 root root 17 Sep  2  2011 atlas-x86_64.conf
-r--r--r--. 1 root root 63 May  7 18:27 kernel-3.3.4-5.fc17.x86_64.debug.conf
-r--r--r--. 1 root root 63 May 25 21:08 kernel-3.3.7-2.fc17.x86_64.conf
-r--r--r--. 1 root root 63 May 25 20:34 kernel-3.3.7-2.fc17.x86_64.debug.conf
-r--r--r--. 1 root root 63 Jun  3 07:53 kernel-3.4.0-1.fc17.x86_64.conf
-r--r--r--. 1 root root 63 Jun  3 07:30 kernel-3.4.0-1.fc17.x86_64.debug.conf
-r--r--r--. 1 root root 63 Jul  6 17:09 kernel-3.5.0-0.rc5.git3.1.fc18.x86_64.conf
-rw-r--r--. 1 root root 16 Jul  4 15:48 llvm-x86_64.conf
-rw-r--r--. 1 root root 17 Apr 28 06:52 mysql-x86_64.conf
-rw-r--r--. 1 root root 24 May 20 06:08 tracker-x86_64.conf
-rw-r--r--. 1 root root 23 Jun  5 12:47 xulrunner-64.conf


dracut-020-51.git20120706.fc18.x86_64
glibc-2.16-2.fc18.x86_64
glibc-2.16-2.fc18.i686
systemd-186-1.fc18.x86_64
kernel-3.3.7-2.fc17.x86_64
kernel-3.4.0-1.fc17.x86_64  <-- running kernel
kernel-3.5.0-0.rc5.git3.1.fc18.x86_64  <-- trying to boot this one
Comment 3 Richard W.M. Jones 2012-07-08 12:51:12 EDT
I downgraded to dracut 020-22.git20120702.fc18.x86_64
and it is able to create an initramfs of a normal-looking
size (haven't tried to boot with it yet though ...)

# ls -l /boot/initramfs-3.5.0-0.rc5.git3.1.fc18.x86_64.img 
-rw-r--r--. 1 root root 19290844 Jul  8 18:49 /boot/initramfs-3.5.0-0.rc5.git3.1.fc18.x86_64.img
Comment 4 Harald Hoyer 2012-07-09 02:31:13 EDT
fixed with dracut-020-52

*** This bug has been marked as a duplicate of bug 838367 ***

Note You need to log in before you can comment on or make changes to this bug.