Bug 838124 - Updates disk does not work (invalid paths)
Updates disk does not work (invalid paths)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 13:35 EDT by Carl Roth
Modified: 2012-07-06 14:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 14:47:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2012-07-06 13:35:25 EDT
Description of problem:

The anaconda that ships with Fedora 17 does not work with an updates image.  The same updates image that works with F15 and F16 does not work with F17.

Version-Release number of selected component (if applicable):

Unknown, the Anaconda that ships with Fedora 17.  The bug is also evident from looking at the latest Anaconda git sources.

How reproducible:

Always

Steps to Reproduce:
1. Create an updates disk with updates_disk_hook.py or a custom installclass
2.
3.
  
Actual results:

Updates disk contents are ignored

Expected results:


Additional info:

There are several bugs at work here I think.  I was able to find workarounds for them, but here is what I found:

- Previous Fedora versions extract the updates disk to /tmp/updates

- Current F17 Anaconda uses dracut (I think) to extract the updates disk to /

- The Anaconda executable (Pthon script) is invoked with CWD set to /root

- The updates_disk_hook.py script is imported from anaconda using the current Python path, which includes /tmp/updates, but not / or /root

- Custom installclasses are searched in pyanaconda/installclass.py (availableClasses()) via "installclasses" (relative path to CWD or anaconda script location, not entirely sure) and /tmp/updates/pyanaconda/installclasses


Anyway, to make F17 recognize my updates disk, it's necessary to manually move the components of the updates disk down to /tmp/updates.

The fix I think is to either change where dracut extracts the updates disk, or to fix up the (many) references in the anaconda/pyanaconda sources to /tmp/updates.
Comment 1 David Lehman 2012-07-06 14:47:31 EDT
You should not expect an updates disk from f16 to work in f17. The anaconda sources include a script (scripts/makeupdates) which you can use to create an updates image -- that is what you should use instead of whatever you are currently using. Note that the anaconda source should match the version you plan to use the updates image with -- that means you should use scripts/makeupdates from anaconda-17.xxx to make updates images for F17.

I am going to close this report since I'm fairly sure it is not a bug. If you are already using anaconda-17 scripts/makeupdates and are still having the _same_ issues, please reopen the bug with details of the failure.

Note You need to log in before you can comment on or make changes to this bug.