Bug 83813 - openvt can't execute progs in specified console
openvt can't execute progs in specified console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-09 03:20 EST by hvv
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 17:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hvv 2003-02-09 03:20:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
Calling openvt e.g. like this:
openvt -c 10 -s /bin/bash
doesn't start new shell on the specified console - it just switches
to it. Same with the openvt from rh73.
  NB that 'open' from console-tools shipped with RH60 works just
fine - and I'm using it as a substitution for 'openvt' in RH73.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run 'openvt -c 8 -s /bin/sh' as root
    

Actual Results:  console#8 becomes current,- but nothing gets started there.

Expected Results:  console8 becomes current and shell starts there.

Additional info:

I use open/openvt to open log viewers and performance display tools
on consoles from 9 to 12.
Comment 1 Eido Inoue 2004-08-23 17:12:50 EDT
works for me on valid console #s that aren't in use (unless you use
--force) on current release

Note You need to log in before you can comment on or make changes to this bug.