Bug 83815 - need ability to create software RAID1 arrays with only 1 member
Summary: need ability to create software RAID1 arrays with only 1 member
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-09 08:38 UTC by hvv
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-11 17:42:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hvv 2003-02-09 08:38:46 UTC
Description of problem:

Currently anaconda enforces RAID1 arrays to have at least 2 members. This is
unreasonable since it disallows to e.g. install system only on 1 hdd, and then
add the 2nd to the system and turn it into the raid1 arrays' member (by editing
/etc/raidtab, adding partitions of the 2nd hdd as failed-disk, then remaking
raid arrays with mkraid and then hotadd'ing partitions of the 2nd HDD to the
raid arrays).
.
I had to hack installer and burn cusom disk1 to be able to make RAID1 arrays
with only 1 member in order to be able to install system on only one hdd.

FYI mandrake installer does allow to have only 1 member of raid1 array (and did
allow this for agaes AFAIK).

Comment 1 Jeremy Katz 2003-02-10 20:07:14 UTC
This isn't something we're planning to support currently. 

Comment 2 hvv 2003-02-11 10:09:51 UTC
Why then close this bug with WONTFIX?
May be set a resolution to DEFFERED in order not to forget to implement
it later?
Reopened.

Comment 3 Michael Fulbright 2003-02-11 17:42:52 UTC
We do not plan to support this mode of RAID creation.


Note You need to log in before you can comment on or make changes to this bug.