Bug 838228 - symbol lookup error: /lib64/libOSMesa.so.8: undefined symbol: _glapi_Dispatch
symbol lookup error: /lib64/libOSMesa.so.8: undefined symbol: _glapi_Dispatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 11:46 EDT by Kyrre Ness Sjøbæk
Modified: 2012-09-29 05:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:55:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from ~$ strace paraview 2> paraStrace.txt (116.77 KB, text/plain)
2012-07-07 11:46 EDT, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2012-07-07 11:46:05 EDT
Created attachment 596771 [details]
output from ~$ strace paraview 2> paraStrace.txt

Description of problem:
Trying to start paraview from the command line only yields the following message:
$ paraview 
/usr/lib64/paraview/paraview: symbol lookup error: /lib64/libOSMesa.so.8: undefined symbol: _glapi_Dispatch

Version-Release number of selected component (if applicable):
paraview-3.14.1-3.fc17.x86_64

How reproducible:
Every time

Additional info:
Nvidia driver installed and loaded (akmod from rpmfusion). Paraview worked fine in Fedora 16.
Comment 1 Kyrre Ness Sjøbæk 2012-07-07 12:25:54 EDT
Also, the paraview binary (3.14.1 / tar.gz / 64-bit) from the kitware website seems to work.
Comment 2 Orion Poplawski 2012-07-10 00:01:38 EDT
I think this a problem with the linking of libOSMesa:

mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_Dispatch
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_Context
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_get_proc_address
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_get_dispatch_table_size
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_get_dispatch
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_get_context
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_add_dispatch
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_check_multithread
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_set_context
mesa-libOSMesa.i686: W: undefined-non-weak-symbol /usr/lib/libOSMesa.so.8.0.3 _glapi_set_dispatch

libOSMesa.so.8 is not linked to libglapi.
Comment 3 Kyrre Ness Sjøbæk 2012-07-17 08:21:01 EDT
Just updated to mesa from 8.0.3-1 to 8.0.3-3, nothing changed.
Comment 4 markusN 2012-08-07 09:37:46 EDT
Same problem here on F17, 64bit.
Comment 5 Fedora Update System 2012-08-27 12:33:51 EDT
mesa-8.1-0.19.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mesa-8.1-0.19.fc18
Comment 6 Fedora Update System 2012-08-28 14:15:43 EDT
Package mesa-8.1-0.19.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-8.1-0.19.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12852/mesa-8.1-0.19.fc18
then log in and leave karma (feedback).
Comment 7 Torsten Rohlfing 2012-08-28 16:17:21 EDT
Any chance this will be fixed in F17 also? F18 is, after all, not even alpha yet.
Comment 8 Fedora Update System 2012-09-17 18:55:52 EDT
mesa-8.1-0.19.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 markusN 2012-09-18 12:01:19 EDT
Since F18 is still alpha, please backport the fix to F17. thanks!
Comment 10 Tyson Whitehead 2012-09-28 18:31:47 EDT
There is another deeper issue here as well.  As discussed in this bug report and the mesa mailing list threads it links to

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=744434

it isn't actually correct to use both libGL and libOSMesa at the same time.

This was fixed in VTK awhile back (you have to compile VTK without -DVTK_OPENGL_HAS_OSMESA:BOOL=ON), but paraview was missed as it has it's own copy.

Currently we are getting away with it, but it is a sitting time bomb.  Whether or not it bites you depends on linking order, functions used, and such.

Cheers!  -Tyson
Comment 11 markusN 2012-09-29 05:15:15 EDT
(In reply to comment #10)
...
> This was fixed in VTK awhile back (you have to compile VTK without
> -DVTK_OPENGL_HAS_OSMESA:BOOL=ON), but paraview was missed as it has it's own
> copy.

There is a related bug 697842 on the private VTK copy of Paraview.

Note You need to log in before you can comment on or make changes to this bug.