Bug 838230 - systemd repair mode is hosing the rootfs
systemd repair mode is hosing the rootfs
Status: CLOSED DUPLICATE of bug 838367
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-07-07 11:57 EDT by Bruno Wolff III
Modified: 2012-07-09 07:53 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 07:53:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a systemd log from one failed boot attempt (84.32 KB, text/plain)
2012-07-07 12:19 EDT, Bruno Wolff III
no flags Details
This is what got written to /etc/profile (35 bytes, text/plain)
2012-07-07 12:20 EDT, Bruno Wolff III
no flags Details
This shows ths sysroot line appended to /etc/fstab (821 bytes, text/plain)
2012-07-07 12:21 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2012-07-07 11:57:48 EDT
Description of problem:
While trying to get data for some other systemd/plmouth/dracut issues blocking booting with new initramfs images a new bug has showed up where I can't even boot from old initramfs images. I get dumped into a repair mode with no networking (making it hard to capture data). My rootfs system is mounted, but systemd may be behaving as though the root pivot hasn't happened yet. It wrote over /etc/profile to change the shell prompt and appends a line to /etc/fstab every boot attempt for mounting sysroot. On one machine the rootfs got corrupted, but I suspect I might have done some damage trying to work out of the problem.
Unfortunately because of the change in prerequisites in several related packages it is very difficult for me to revert back to systemd 19 in order to have a usable system again.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2012-07-07 12:19:44 EDT
Created attachment 596778 [details]
This is a systemd log from one failed boot attempt
Comment 2 Bruno Wolff III 2012-07-07 12:20:42 EDT
Created attachment 596779 [details]
This is what got written to /etc/profile
Comment 3 Bruno Wolff III 2012-07-07 12:21:45 EDT
Created attachment 596780 [details]
This shows ths sysroot line appended to /etc/fstab
Comment 4 Harald Hoyer 2012-07-09 07:53:23 EDT
sorry, see https://bugzilla.redhat.com/show_bug.cgi?id=838367#c7

*** This bug has been marked as a duplicate of bug 838367 ***

Note You need to log in before you can comment on or make changes to this bug.