Bug 838279 - [abrt] cheese-3.4.2-3.fc17: v4lconvert_yuyv_to_yuv420: Process /usr/bin/cheese was killed by signal 11 (SIGSEGV)
[abrt] cheese-3.4.2-3.fc17: v4lconvert_yuyv_to_yuv420: Process /usr/bin/chees...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: v4l-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:7f16e794c7f56a9d8bad77e8956...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 04:17 EDT by Brandon
Modified: 2012-07-20 22:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 22:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (30.17 KB, text/plain)
2012-07-08 04:17 EDT, Brandon
no flags Details
File: maps (55.00 KB, text/plain)
2012-07-08 04:17 EDT, Brandon
no flags Details
File: dso_list (11.17 KB, text/plain)
2012-07-08 04:17 EDT, Brandon
no flags Details
File: build_ids (4.56 KB, text/plain)
2012-07-08 04:17 EDT, Brandon
no flags Details
LIBV4L2_LOG_FILENAME=/tmp/log (53.98 KB, application/octet-stream)
2012-07-08 17:37 EDT, Brandon
no flags Details

  None (edit)
Description Brandon 2012-07-08 04:17:39 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/cheese
comment:        Open Cheese, receive segfault. https://bugzilla.redhat.com/show_bug.cgi?id=810429
crash_function: v4lconvert_yuyv_to_yuv420
executable:     /usr/bin/cheese
kernel:         3.4.3-1.fc17.x86_64
pid:            6676
pwd:            /home/lordnynex/Documents
time:           Sun 08 Jul 2012 12:44:50 AM PDT
uid:            1000
username:       lordnynex

backtrace:      Text file, 30895 bytes
build_ids:      Text file, 4674 bytes
dso_list:       Text file, 11437 bytes
maps:           Text file, 56321 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/lordnynex/3

core_backtrace:
:0f16c1a299168b76320a8c2ca09067e546f162a7 0xebfc - libv4lconvert.so.0 -
:0f16c1a299168b76320a8c2ca09067e546f162a7 0x5580 - libv4lconvert.so.0 -
:0f16c1a299168b76320a8c2ca09067e546f162a7 0x5de0 v4lconvert_convert libv4lconvert.so.0 -
:7e825b44f101b8534af7b515d47da7c0c9813601 0x2ae4 - libv4l2.so.0 -
:7e825b44f101b8534af7b515d47da7c0c9813601 0x3e79 v4l2_ioctl libv4l2.so.0 -
:5ba3e1c940fef85250e7ac4510b2072f2b2949f9 0xb4cf - libgstvideo4linux2.so -
:5ba3e1c940fef85250e7ac4510b2072f2b2949f9 0x139e2 - libgstvideo4linux2.so -
:5ba3e1c940fef85250e7ac4510b2072f2b2949f9 0xd2fd - libgstvideo4linux2.so -
:5ba3e1c940fef85250e7ac4510b2072f2b2949f9 0xd9ac - libgstvideo4linux2.so -
:113d32f002d1119cd3b6a249c1c5b76e86b7a770 0x26bdc - libgstbase-0.10.so.0 -
:113d32f002d1119cd3b6a249c1c5b76e86b7a770 0x27ef0 - libgstbase-0.10.so.0 -
:f23f8759450275e5e7c4881c8d6dcdec0554a0ce 0x82d64 - libgstreamer-0.10.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x6ab12 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x6a315 - libglib-2.0.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:SSH_AGENT_PID=5293
:HOSTNAME=citadel
:DM_CONTROL=/var/run/xdmctl
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:HISTSIZE=1000
:XDM_MANAGED=method=classic
:GTK2_RC_FILES=/home/lordnynex/.gtkrc-2.0-kde4
:GS_LIB=
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:KDE_FULL_SESSION=true
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=lordnynex
:SSH_AUTH_SOCK=/tmp/ssh-AizOLCgF5253/agent.5253
:MAIL=/var/spool/mail/lordnynex
:DESKTOP_SESSION=default
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/lordnynex/.local/bin:/home/lordnynex/bin
:PWD=/home/lordnynex
:KDE_SESSION_UID=1000
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/lordnynex
:KDE_SESSION_VERSION=4
:LOGNAME=lordnynex
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-IxWKV51jSP,guid=b5e5548bc2fb5930a2e0698a00000ad8
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/lordnynex
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/lordnynex/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:XAUTHORITY=/tmp/kde-lordnynex/xauth-1000-_0
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:KDE_MULTIHEAD=false
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/5352,unix/unix:/tmp/.ICE-unix/5352
:LANGUAGE=
:DESKTOP_STARTUP_ID=citadel;1341733486;93415;5366_TIME6724171

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31462                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31462                31462                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[912540]
:pos:	0
:flags:	00
:1:/home/lordnynex/.xsession-errors
:pos:	98253
:flags:	0100001
:2:/home/lordnynex/.xsession-errors
:pos:	98253
:flags:	0100001
:3:socket:[914677]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:/dev/dri/card0
:pos:	0
:flags:	0100002
:6:socket:[914709]
:pos:	0
:flags:	02004002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[914712]
:pos:	0
:flags:	02004002
:10:socket:[380188]
:pos:	0
:flags:	02
:11:anon_inode:inotify
:pos:	0
:flags:	02004000
:12:socket:[912656]
:pos:	0
:flags:	02004002
:13:socket:[914751]
:pos:	0
:flags:	04002
:14:socket:[914752]
:pos:	0
:flags:	04002
:15:/dev/video0
:pos:	0
:flags:	0100002
:16:socket:[914762]
:pos:	0
:flags:	04002
:17:socket:[914763]
:pos:	0
:flags:	04002

smolt_data:
:
:
:General
:=================================
:UUID: d71bd2e5-642e-4af8-b30d-59fc84b4b023
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5667.14
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 4
:CPU Speed: 2833
:System Memory: 3954
:System Swap: 9829
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.4.3-1.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(4318:620:4163:33438) pci, snd_hda_intel, MULTIMEDIA, MCP51 High Definition Audio
:(4318:623:4318:52100) pci, None, PCI/PCI, MCP51 PCI Bridge
:(4318:612:4163:33212) pci, None, SERIAL, A8N-VM CSM Mainboard
:(4318:608:4163:33212) pci, None, PCI/ISA, A8N-VM CSM Mainboard
:(4318:931:0:0) pci, None, HOST/PCI, C55 Host Bridge
:(4318:937:0:0) pci, None, RAM, C55 Memory Controller
:(4318:938:0:0) pci, None, RAM, C55 Memory Controller
:(4318:947:0:0) pci, None, RAM, C55 Memory Controller
:(4318:946:0:0) pci, None, RAM, C55 Memory Controller
:(4318:945:0:0) pci, None, RAM, C55 Memory Controller
:(4318:944:0:0) pci, None, RAM, C55 Memory Controller
:(4318:943:0:0) pci, None, RAM, C55 Memory Controller
:(4318:942:0:0) pci, None, RAM, C55 Memory Controller
:(4318:941:0:0) pci, None, RAM, C55 Memory Controller
:(4318:940:0:0) pci, None, RAM, C55 Memory Controller
:(4318:1471:0:0) pci, pcieport, PCI/PCI, N/A
:(4318:949:0:0) pci, None, RAM, C55 Memory Controller
:(4318:1471:0:0) pci, pcieport, PCI/PCI, N/A
:(4318:948:0:0) pci, None, RAM, C55 Memory Controller
:(4318:1471:0:0) pci, pcieport, PCI/PCI, N/A
:(4318:939:0:0) pci, None, RAM, C55 Memory Controller
:(4318:617:4163:33313) pci, forcedeth, BRIDGE, MCP51 Ethernet Controller
:(4318:1471:0:0) pci, pcieport, PCI/PCI, N/A
:(4318:936:0:0) pci, None, RAM, C55 Memory Controller
:(4318:1600:14402:51545) pci, nouveau, VIDEO, G96 [GeForce 9500 GT]
:(4318:950:0:0) pci, None, RAM, C55 Memory Controller
:(4318:956:0:0) pci, None, RAM, C55 Memory Controller
:(4318:954:0:0) pci, None, RAM, C55 Memory Controller
:(4318:951:4318:3157) pci, pcieport, PCI/PCI, C55 PCI Express bridge
:(4318:626:4163:33212) pci, None, RAM, MCP51 Memory Controller 0
:(4318:1471:0:0) pci, pcieport, PCI/PCI, N/A
:(4318:613:4163:33212) pci, pata_amd, STORAGE, A8N-VM CSM Mainboard
:(4318:624:4163:33212) pci, None, RAM, A8N-VM CSM Mainboard
:(4318:614:4163:33212) pci, sata_nv, STORAGE, A8N-VM CSM Mainboard
:(4318:615:4163:33212) pci, sata_nv, STORAGE, A8N-VM CSM Mainboard
:(4318:621:4163:33212) pci, ohci_hcd, USB, A8N-VM CSM Mainboard
:(4318:622:4163:33212) pci, ehci_hcd, USB, A8N-VM CSM Mainboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_citadel-lv_root / ext4 4096 4096 13091841 11241886 11110836 3276800 3124945 3124945
:/dev/sda1 /boot ext4 1024 1024 508644 422364 396764 128016 127616 127616
:/dev/mapper/vg_citadel-lv_home /home ext4 4096 4096 229164161 213390640 201920202 57352192 56687300 56687300
:

var_log_messages:
:Jul  8 00:43:48 citadel yum[6610]: Installed: 2:cheese-libs-3.4.2-3.fc17.x86_64
:Jul  8 00:43:49 citadel yum[6610]: Installed: 2:cheese-3.4.2-3.fc17.x86_64
:Jul  8 00:44:51 citadel abrt[6684]: Saved core dump of pid 6676 (/usr/bin/cheese) to /var/spool/abrt/ccpp-2012-07-08-00:44:50-6676 (88666112 bytes)

xsession_errors:
:Failed to find service for  QUrl( "krunner://shell/shell_cheese" )  
:abrt-applet: repeated problem in cheese-3.4.2-3.fc17, not showing the notification
Comment 1 Brandon 2012-07-08 04:17:42 EDT
Created attachment 596854 [details]
File: backtrace
Comment 2 Brandon 2012-07-08 04:17:43 EDT
Created attachment 596855 [details]
File: maps
Comment 3 Brandon 2012-07-08 04:17:44 EDT
Created attachment 596856 [details]
File: dso_list
Comment 4 Brandon 2012-07-08 04:17:46 EDT
Created attachment 596857 [details]
File: build_ids
Comment 5 Brandon 2012-07-08 04:18:40 EDT

*** This bug has been marked as a duplicate of bug 810429 ***
Comment 6 Hans de Goede 2012-07-08 05:40:54 EDT
Looking at the backtrace this is a completely different bug then bug 810429 . The problem most people with tv/radio devices were having is that cheese crashed while enumerating video devices. Your trace-back is way past that point, when cheese is actually trying to stream video from the device, and happens inside libv4l rather then inside cheese itself -> re-opening this one to track the crash you're seeing.
Comment 7 Hans de Goede 2012-07-08 05:43:36 EDT
Hi Brandon,

I would like to try and reproduce the crash you're seeing. So I've a few questions:

1) Is this crash reproducable, iow if you try cheese again it crashes again ?
2) What video hardware are you using? Can you attach the output of lspci and lsusb here to help me identify it?
3) Assuming the answer to 1 is yes, can you do the following from a terminal:
export LIBV4L2_LOG_FILENAME=/tmp/log
cheese
Then wait for cheese to crash, and after the crash attach /tmp/log here?

Thanks,

Hans
Comment 8 Brandon 2012-07-08 17:37:02 EDT
(In reply to comment #7)

> 
> 1) Is this crash reproducable, iow if you try cheese again it crashes again ?

Yes. Start up and segfault immediately. It is worth noting that the cheese window does display some video from the camera before it segfaults. 

> 2) What video hardware are you using? Can you attach the output of lspci and
> lsusb here to help me identify it?

Nvidia Gforce 9500 GT.  Output is below. 

> 3) Assuming the answer to 1 is yes, can you do the following from a terminal:
> export LIBV4L2_LOG_FILENAME=/tmp/log
> cheese
> Then wait for cheese to crash, and after the crash attach /tmp/log here?
> 


Below is lsusb. It is worth noting that this is a 7M USB endoscope. It is a generic chinese camera that identifies as 'Generic USB Camera' on OS X and Windows. 

$ lsusb
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 010: ID 0bda:5801 Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 049f:0051 Compaq Computer Corp. KU-0133 Easy Access Interner Keyboard
Bus 002 Device 003: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 012: ID 0548:1005 Tyan Computer Corp. EZ Cart II GameBoy Flash Programmer
Bus 001 Device 007: ID 0471:485d Philips (or NXP) Senselock SenseIV v2.x


$ lspci
00:00.0 Host bridge: nVidia Corporation C55 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.3 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.4 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.5 RAM memory: nVidia Corporation C55 Memory Controller (rev a2)
00:00.6 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.7 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.0 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.3 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.4 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.5 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.6 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.0 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:03.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
01:00.0 PCI bridge: nVidia Corporation Device 05bf (rev a2)
02:00.0 PCI bridge: nVidia Corporation Device 05bf (rev a2)
02:01.0 PCI bridge: nVidia Corporation Device 05bf (rev a2)
02:02.0 PCI bridge: nVidia Corporation Device 05bf (rev a2)
02:03.0 PCI bridge: nVidia Corporation Device 05bf (rev a2)
03:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9500 GT] (rev a1)
07:08.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)


DMESG:

[56534.478015] usb 1-8: new high-speed USB device number 13 using ehci_hcd
[56535.138751] usb 1-8: New USB device found, idVendor=0bda, idProduct=5801
[56535.138754] usb 1-8: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[56535.138757] usb 1-8: Product: USB Camera
[56535.138759] usb 1-8: Manufacturer: Generic
[56535.138761] usb 1-8: SerialNumber: 200901010001
[56535.148036] uvcvideo: Found UVC 1.00 device USB Camera (0bda:5801)
[56535.166367] input: USB Camera as /devices/pci0000:00/0000:00:0b.1/usb1/1-8/1-8:1.0/input/input14
Comment 9 Brandon 2012-07-08 17:37:54 EDT
Created attachment 596927 [details]
LIBV4L2_LOG_FILENAME=/tmp/log
Comment 10 Hans de Goede 2012-07-09 07:13:04 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > 2) What video hardware are you using? Can you attach the output of lspci and
> > lsusb here to help me identify it?
> 
> Nvidia Gforce 9500 GT.  Output is below. 
> 

I meant video input hardware not video output hardware, looking at the lspci / lsusb output you
only have the UVC USB device as video input devices and no tv-cards / radio devices, etc. correct?

(In reply to comment #9)
> Created attachment 596927 [details]
> LIBV4L2_LOG_FILENAME=/tmp/log

Ah, now that one is very useful. So the problem seems to be that sometimes the
UVC device returns incomplete frames, from the log:

libv4l2: warning error while converting frame data: v4l-convert: error short yu
request == VIDIOC_DQBUF
result == 0

This one is fine, as libv4l2 automatically retries and that succeeds, further down the log we've:

libv4l2: warning error while converting frame data: v4l-convert: error short yu
libv4l2: warning error while converting frame data: v4l-convert: error short yu
libv4l2: warning error while converting frame data: v4l-convert: error short yu
libv4l2: warning error while converting frame data: v4l-convert: error short yu
libv4l2: got 4 consecutive short frame errors, returning short frame
request == VIDIOC_DQBUF
result == 0

And then the next qbuf fails, this is because of a bug in libv4l2 where it requeues the buffer on an error which is retry-able, even if it is the last try! So then gstreamer tries to re-queue the already re-queued buf, and things go downhill from there.

I'll prepare an update fixing this.
Comment 11 Fedora Update System 2012-07-09 09:06:30 EDT
v4l-utils-0.8.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/v4l-utils-0.8.8-2.fc17
Comment 12 Fedora Update System 2012-07-09 09:07:35 EDT
v4l-utils-0.8.8-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/v4l-utils-0.8.8-2.fc16
Comment 13 Hans de Goede 2012-07-09 09:10:23 EDT
Brandon,

You can grab the new libv4l here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=329558

Download the version for your arch, and then do:
sudo rpm -Uvh libv4l*.rpm

And then try again please.

Thanks & Regards,

Hans
Comment 14 Fedora Update System 2012-07-10 12:24:26 EDT
Package v4l-utils-0.8.8-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing v4l-utils-0.8.8-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10423/v4l-utils-0.8.8-2.fc16
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-07-20 22:49:11 EDT
v4l-utils-0.8.8-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-07-20 22:54:38 EDT
v4l-utils-0.8.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.