Bug 838298 - [abrt] libreoffice-core-3.5.4.2-4.fc17: ToolbarLayoutManager::implts_setDockingAreaWindowSizes killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.4.2-4.fc17: ToolbarLayoutManager::implts_setDocki...
Status: CLOSED DUPLICATE of bug 1005571
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:59ffd6abafe2937733dba8a9921...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 06:47 EDT by Misha Shnurapet
Modified: 2013-09-09 03:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 16:15:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (94.96 KB, text/plain)
2012-07-08 06:47 EDT, Misha Shnurapet
no flags Details
File: dso_list (15.13 KB, text/plain)
2012-07-08 06:47 EDT, Misha Shnurapet
no flags Details
File: smolt_data (2.94 KB, text/plain)
2012-07-08 06:47 EDT, Misha Shnurapet
no flags Details
File: backtrace (72.37 KB, text/plain)
2012-07-08 06:47 EDT, Misha Shnurapet
no flags Details

  None (edit)
Description Misha Shnurapet 2012-07-08 06:47:07 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --quickstart --nologo --nodefault
crash_function: framework::ToolbarLayoutManager::implts_setDockingAreaWindowSizes
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.4.4-3.fc17.x86_64
pid:            2402
pwd:            /
time:           Вс. 08 июля 2012 18:31:33
uid:            1000
username:       misha

backtrace:      Text file, 74108 bytes
dso_list:       Text file, 15495 bytes
maps:           Text file, 97237 bytes
smolt_data:     Binary file, 3010 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/misha/2

core_backtrace:
:c044aedab45db02f45f3a641c47cbefb5120c504 0xeb40c - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0xfce1a - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0xe31ac - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0xe34da - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0x141403 - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0x1495a7 - libfwklo.so -
:ae76c60e6b1c941e20169b018193adbbdd1cdf62 0x3121cc - libsfxlo.so -
:ae76c60e6b1c941e20169b018193adbbdd1cdf62 0x313c5b - libsfxlo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0x10c233 - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0x10d598 - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0xa5b7e - libfwklo.so -
:c044aedab45db02f45f3a641c47cbefb5120c504 0xa60a8 - libfwklo.so -
:42273843804afad86267b22a5db2f59adac402f4 0xd5ea4 comphelper::SynchronousDispatch::dispatch(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> libcomphelpgcc3.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x334f7 - libsofficeapp.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x40ff1 - libsofficeapp.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x41595 - libsofficeapp.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x352d12 - libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x35c3c1 SalGenericDisplay::DispatchInternalEvent() libvcllo.so -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x30fcf - libvclplug_gtklo.so -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x31049 - libvclplug_gtklo.so -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47ad4 g_main_context_iteration libglib-2.0.so.0 -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x30dd1 - libvclplug_gtklo.so -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x31acd - libvclplug_gtklo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0xfbbe4 Application::Yield(bool) libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0xfbc87 Application::Execute() libvcllo.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x1dd59 - libsofficeapp.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x102621 - libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x1026c5 SVMain() libvcllo.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x41d36 soffice_main libsofficeapp.so -
:18ffb5d5f97d5a9e8dc0acd3f6ae0aa87917dc08 0x6bb - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=saw
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/misha/keyring-cgDl6S/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:OLDPWD=/usr/lib64/libreoffice/program
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/misha/keyring-cgDl6S
:QTINC=/usr/lib64/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:'IMSETTINGS_MODULE=X compose table'
:USER=misha
:DESKTOP_AUTOSTART_ID=10c3e9899e9d23bee0134167499022504400000016310003
:SSH_AUTH_SOCK=/run/user/misha/keyring-cgDl6S/ssh
:USERNAME=misha
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1631,unix/unix:/tmp/.ICE-unix/1631
:MAIL=/var/spool/mail/misha
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/misha/.local/bin:/home/misha/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1626
:LANG=ru_RU.utf8
:GDM_LANG=ru_RU.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/misha
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=misha
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-afxtRZe564,guid=743af87e66d525bcaa85db5300000037
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/misha
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-misha-w2wJgf/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30936                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30936                30936                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/dev/null
:pos:	0
:flags:	0102002
:2:/dev/null
:pos:	0
:flags:	0102002
:3:socket:[25286]
:pos:	0
:flags:	02004002
:4:pipe:[25217]
:pos:	0
:flags:	00
:5:pipe:[25217]
:pos:	0
:flags:	01
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[25288]
:pos:	0
:flags:	02000002
:8:socket:[53020]
:pos:	0
:flags:	02000002
:9:socket:[25440]
:pos:	0
:flags:	02004002
:10:/usr/lib64/libreoffice/program/resource/fweru.res
:pos:	3070
:flags:	0100000
:11:/usr/lib64/libreoffice/program/resource/sbru.res
:pos:	10120
:flags:	0100000
:12:/usr/lib64/libreoffice/program/resource/ofaru.res
:pos:	12454
:flags:	0100000
:13:/usr/lib64/libreoffice/program/resource/svtru.res
:pos:	19540
:flags:	0100000
:14:/home/misha/.execoooIiQy2B (deleted)
:pos:	0
:flags:	0100002
:15:/usr/lib64/libreoffice/program/resource/sfxru.res
:pos:	17330
:flags:	0100000
:16:/usr/lib64/libreoffice/program/resource/vclru.res
:pos:	8402
:flags:	0100000
:17:/usr/lib64/libreoffice/share/config/images_tango.zip
:pos:	0
:flags:	0100000
:18:/usr/lib64/libreoffice/program/resource/deploymentru.res
:pos:	3184
:flags:	0100000
:19:/home/misha/.config/libreoffice/3/user/extensions/shared/extensions.db
:pos:	0
:flags:	02100002
:20:/home/misha/.config/libreoffice/3/user/extensions/bundled/extensions.db
:pos:	0
:flags:	02100002
:21:/home/misha/.config/libreoffice/3/user/uno_packages/cache/log.txt
:pos:	0
:flags:	0100002
:22:/home/misha/.config/libreoffice/3/user/uno_packages/cache/uno_packages.db
:pos:	0
:flags:	02100002
:23:socket:[26666]
:pos:	0
:flags:	02000002
:24:pipe:[26667]
:pos:	0
:flags:	02004000
:25:pipe:[26667]
:pos:	0
:flags:	02004001
:26:/mnt/Storage/!!Работа.odt
:pos:	0
:flags:	0100002
:27:/usr/lib64/libreoffice/program/resource/swru.res
:pos:	158424
:flags:	0100000
:28:/usr/lib64/libreoffice/program/resource/svxru.res
:pos:	80052
:flags:	0100000
:29:/tmp/lucunt1d.tmp/lucunt1e.tmp
:pos:	0
:flags:	0100002
:30:/dev/urandom
:pos:	0
:flags:	02100000
:31:socket:[293756]
:pos:	0
:flags:	02000002
:32:/usr/lib64/libreoffice/program/resource/editengru.res
:pos:	14220
:flags:	0100000
:33:socket:[293760]
:pos:	0
:flags:	02004002
:34:anon_inode:inotify
:pos:	0
:flags:	02004000
:35:socket:[293762]
:pos:	0
:flags:	02004002

var_log_messages:
:Jul  8 18:31:33 saw kernel: [22494.320433] soffice.bin[2402]: segfault at 0 ip 00007f7d2ed3940c sp 00007fff9fff38a0 error 4 in libfwklo.so[7f7d2ec4e000+280000]
:Jul  8 18:31:33 saw abrt[27936]: File '/usr/lib64/libreoffice/program/soffice.bin' seems to be deleted
:Jul  8 18:31:34 saw abrt[27936]: Saved core dump of pid 2402 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-07-08-18:31:33-2402 (75309056 bytes)
Comment 1 Misha Shnurapet 2012-07-08 06:47:15 EDT
Created attachment 596867 [details]
File: maps
Comment 2 Misha Shnurapet 2012-07-08 06:47:18 EDT
Created attachment 596868 [details]
File: dso_list
Comment 3 Misha Shnurapet 2012-07-08 06:47:24 EDT
Created attachment 596869 [details]
File: smolt_data
Comment 4 Misha Shnurapet 2012-07-08 06:47:29 EDT
Created attachment 596870 [details]
File: backtrace
Comment 5 Caolan McNamara 2012-07-09 07:40:11 EDT
Appears to be a crash on starting the systray quickstarter. But doing that here locally on F-17 works fine for me.

Does this crash for you on every login ? Or was there specific circumstances ?
It it always crashes, are you using KDE or GNOME3 or something else ?
Comment 6 Caolan McNamara 2012-09-11 16:15:12 EDT
can't reproduce this, so have to close it out as worksforme. (unless there's a chance that this is the return of quickstarter running, rpms upgraded, quickstarter referencing old deleted libs, then quickstarter used to launch new component => random crashes. Which is in theory fixed by using gio to see if the app has been upgraded and restart/end the quickstarter if that happens.
Comment 7 David Tardon 2013-09-09 03:44:27 EDT

*** This bug has been marked as a duplicate of bug 1005571 ***

Note You need to log in before you can comment on or make changes to this bug.