Bug 838316 - Ctrl-C in editor changes topic validity to "unknown"
Ctrl-C in editor changes topic validity to "unknown"
Status: CLOSED CURRENTRELEASE
Product: Topic Tool
Classification: Other
Component: FUDCon Docs Hack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joshua Wulf
Joshua Wulf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 07:33 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 13:21:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-07-08 07:33:28 EDT
At the moment copying text *from* the editor will change the topic validity state to "unknown".

This is because a keydown event that isn't a meta key or arrow is interpreted as a change to the text.

Two ways to fix this:

1. Intercepting Ctrl-C : http://stackoverflow.com/questions/2903991/how-to-detect-ctrlv-ctrlc-using-javascript

2. Change the event from a keydown to a "text change" event, if one exists.
Comment 1 Joshua Wulf 2012-08-08 13:21:55 EDT
Fixed by moving the event handler to the onChange event.

Note You need to log in before you can comment on or make changes to this bug.