Bug 838331 - running dracut leads to unbootable system
running dracut leads to unbootable system
Status: CLOSED DUPLICATE of bug 838367
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 09:20 EDT by Sandro Mani
Modified: 2012-07-09 02:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 02:44:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2012-07-08 09:20:33 EDT
Description of problem:

Running dracut (through /usr/libexec/plymouth/plymouth-update-initrd, but also a simple dracut -f is sufficient to highlight the problem), I got
---
/sbin/dracut: line 546: unset: prefix: cannot unset: readonly variable
cp: '/usr/lib/kbd/consolefonts' and '/var/tmp/initramfs.uVb5Ve//usr/lib/kbd/consolefonts' are the same file
cp: '/usr/lib/kbd/consoletrans' and '/var/tmp/initramfs.uVb5Ve//usr/lib/kbd/consoletrans' are the same file
cp: '/usr/lib/kbd/keymaps' and '/var/tmp/initramfs.uVb5Ve//usr/lib/kbd/keymaps' are the same file
cp: '/usr/lib/kbd/unimaps' and '/var/tmp/initramfs.uVb5Ve//usr/lib/kbd/unimaps' are the same file
ln: failed to create symbolic link 'default.plymouth': File exists
cp: '/usr/share/terminfo' and '/var/tmp/initramfs.uVb5Ve//usr/share/terminfo' are the same file
egrep: input file '/etc/group' is also the output
root:x:0:0:root:/root:/bin/bash
egrep: input file '/etc/passwd' is also the output
ldconfig: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf: Too many levels of symbolic links
ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Too many levels of symbolic links
E: ldconfig exited ungracefully
---
On reboot, I got
---
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
---
To be able to boot the system again, I had to modify the grub command list by commenting
initrd /boot/initramfs-3.4.4-5.fc17.x86_64.img
and using root=/dev/sda7 rootfstype=ext4 instead of root=UUID=...
I then got dropped to an emergency shell, because of dracut services failing to mount root, on which I completely removed dracut. The next reboot was then successful (albeit having to specify enforcing=0)

Version-Release number of selected component (if applicable):
dracut-020-51.git20120706.fc18

How reproducible:
Always

Steps to Reproduce:
Clean reproducer with
1. Setup a fresh F17 virtual machine
2. Upgrade to rawhide
3. Resulting system is unbootable due to new-kernel-pkg calling dracut when installing the new kernel

Additional info:
I noticed that dracut creates a root directory structure in /var/tmp/dracut***, with bin, etc, lib being symlinks to /etc. During the dracut process, files in /var/tmp/dracut***/etc aka /etc are modified (noticably, I found /sysroot mount entries in /etc/fstab, completely altered /etc/profile and /etc/os-release files, and possibly more I haven't noticed yet). This is hardly supposed to happen? The symlinks are also the reaons for the warning and error messages produced by dracut (and is the reason why ldconfig fails).

Note: I am not using lvm/raid.
Comment 1 Harald Hoyer 2012-07-09 02:44:37 EDT
fixed with dracut-020-52

*** This bug has been marked as a duplicate of bug 838367 ***

Note You need to log in before you can comment on or make changes to this bug.