Bug 838340 - systemctl fails installing a multi-instance service
systemctl fails installing a multi-instance service
Status: CLOSED DUPLICATE of bug 752774
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 10:34 EDT by Richard Neumann
Modified: 2012-07-09 03:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 03:52:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Neumann 2012-07-08 10:34:24 EDT
Description of problem:
When trying to enable a system service, for instance 'openvpn', on boot, openvpn fails to do so.

Version-Release number of selected component (if applicable):
systemd 44
fedora
+PAM +LIBWRAP +AUDIT +SELINUX +IMA +SYSVINIT +LIBCRYPTSETU

How reproducible:
Try to enable a multi intace service, for instance openVPN.

Steps to Reproduce:
1. systemctl enable openvpn@myconfig.service
  
Actual results:
Message "Failed to issue method call: No such file or directory"
with a return code of 1

Expected results:
An empty output with return code of 0.

Additional info:
You can enable such services using the workaround
1. ln -s /lib/systemd/system/openvpn\@.service /etc/systemd/system/multi-user.target.wants/openvpn\@myconfig.service
Comment 1 Richard Neumann 2012-07-08 10:36:51 EDT
Sorry, I made a mistake in the description. It should mean:
When trying to enable a system service, for instance 'openvpn', on boot, _systemctl_ fails to do so
Comment 2 Michal Sekletar 2012-07-09 03:52:01 EDT

*** This bug has been marked as a duplicate of bug 752774 ***

Note You need to log in before you can comment on or make changes to this bug.