Bug 838406 - Have all forms use POST
Have all forms use POST
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
ImplementationQuality
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 22:26 EDT by Raymond Mancy
Modified: 2016-07-27 21:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 21:01:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2012-07-08 22:26:43 EDT
Many of our forms use GET. They should be using POST unless there is a great reason not to.
Comment 4 Dan Callaghan 2016-07-27 03:02:29 EDT
I think the only remaining forms which are improperly submitted using GET are:

/save_note (Notes tab on the system page)
/save_exclude (Excluded Families tab on the system page)
/really_cancel (old job cancellation page)
/tasks/disable_from_ui (Disable button on tasks grid)
/configuration/remove (Clear Current Value button on config grid)
/configuration/save (form on config item page)
/retentiontag/delete (Delete button on retention tags grid)
/retentiontag/save (form on new retention tag page)
/retentiontag/save_edit (form on edit retention tag page)
/keytypes/remove (Remove button on key types grid)
/keytypes/save (form on new key type page and edit key type page)
/osversions/save (form on OS version page)
Comment 5 Roman Joost 2016-07-27 21:00:38 EDT
I'm closing this particular bug, since it is something which will be fixed eventually by moving to back bone and a REST api. Implementing API endpoints and using Backbone will make it much harder to use GET instead of POST (perhaps it's not even possible).

Note You need to log in before you can comment on or make changes to this bug.