This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 838427 - Can't build document when format with space prefix
Can't build document when format with space prefix
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 01:35 EDT by xuezhi ma
Modified: 2012-10-30 23:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description xuezhi ma 2012-07-09 01:35:50 EDT
Description of problem:
When I build a document with command:
$ publican build --formats html, html-desktop --langs en-US

html-desktop will not be generated, because before "html-desktop", there is a space.

Version-Release number of selected component (if applicable):
publican 3.0

How reproducible:
always

Steps to Reproduce:
1. publican build --formats html, html-desktop --langs en-US
2.
3.
  
Actual results:
Only html was generated.

Expected results:
html-desktop also can be generated.

Additional info:
Comment 1 Jeff Fearn 2012-07-09 04:10:59 EDT
Space is not a valid prefix.

The real bug here is that publican isn't catching invalid actions when they aren't the first action.
Comment 2 Jeff Fearn 2012-07-09 04:22:32 EDT
Added code to check number of actions and report an error if there are too many:

$ publican build --formats html, html-desktop --langs en-US
publican only accepts one action you supplied '2': build & html-desktop
 at /usr/bin/publican line 348

To ssh://git.fedorahosted.org/git/publican.git
   c1b69a6..7db69a5  master -> master
Comment 3 Ruediger Landmann 2012-07-11 02:58:09 EDT
Verified in build t207

Note You need to log in before you can comment on or make changes to this bug.