Bug 838442 - [FCoE TGT] Got "TypeError: argument 1 must be string or read-only character buffer, not RTSLibError" when redirect output
[FCoE TGT] Got "TypeError: argument 1 must be string or read-only character b...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Andy Grover
Gris Ge
:
Depends On:
Blocks: 840683
  Show dependency treegraph
 
Reported: 2012-07-09 02:34 EDT by Gris Ge
Modified: 2013-02-21 05:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:48:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0457 normal SHIPPED_LIVE fcoe-target-utils bug fix and enhancement update 2013-02-20 16:07:34 EST

  None (edit)
Description Gris Ge 2012-07-09 02:34:07 EDT
Description of problem:
===========
[root@storageqe-13 ~]# targetcli /tcm_fc/20:00:00:1b:21:59:12:36/acls/ create 10:00:00:05:1e:8f:fa:da
This NodeACL already exists in configFS.
[root@storageqe-13 ~]# targetcli /tcm_fc/20:00:00:1b:21:59:12:36/acls/ create 10:00:00:05:1e:8f:fa:da 1>/dev/null
Traceback (most recent call last):
  File "/usr/bin/targetcli", line 93, in <module>
    main()
  File "/usr/bin/targetcli", line 76, in main
    shell.run_cmdline(" ".join(sys.argv[1:]))
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 934, in run_cmdline
    self._execute_command(path, command, pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/shell.py", line 909, in _execute_command
    result = target.execute_command(command, pparams, kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_node.py", line 84, in execute_command
    pparams, kparams)
  File "/usr/lib/python2.6/site-packages/configshell/node.py", line 1405, in execute_command
    result = method(*pparams, **kparams)
  File "/usr/lib/python2.6/site-packages/targetcli/ui_target.py", line 514, in ui_command_create
    self.shell.log.error(msg)
  File "/usr/lib/python2.6/site-packages/configshell/log.py", line 159, in error
    self._log('error', msg)
  File "/usr/lib/python2.6/site-packages/configshell/log.py", line 112, in _log
    self.con.display(msg)
  File "/usr/lib/python2.6/site-packages/configshell/console.py", line 151, in display
    self.raw_write(text)
  File "/usr/lib/python2.6/site-packages/configshell/console.py", line 139, in raw_write
    self._stdout.write(text)
TypeError: argument 1 must be string or read-only character buffer, not RTSLibError
===========

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb10-5.el6.noarch (RHEL 6.3 GA)

How reproducible:
100%

Steps to Reproduce:
1. Try to redirect command output.
2.
3.
  
Actual results:
Got python failure.

Expected results:
Command output redirected.

Additional info:

Requesting beta blocker. This is a must have feature for all program.
Comment 2 Gris Ge 2012-10-24 22:52:32 EDT
Issue fixed in fcoe-target-utils-2.0rc1.fb16-2.el6.noarch

VERIFY
Comment 4 errata-xmlrpc 2013-02-21 05:48:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0457.html

Note You need to log in before you can comment on or make changes to this bug.