Bug 838451 - udev is throwing " rename(/dev/disk/by-id/wwn-xxx.udev-tmp, /dev/disk/by-id/wwn-xxx) failed: No such file or directory" out
Summary: udev is throwing " rename(/dev/disk/by-id/wwn-xxx.udev-tmp, /dev/disk/by-id/w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 895654
TreeView+ depends on / blocked
 
Reported: 2012-07-09 07:12 UTC by mjin
Modified: 2020-04-15 14:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:29:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0435 normal SHIPPED_LIVE udev bug fix and enhancement update 2013-02-20 20:48:38 UTC

Description mjin 2012-07-09 07:12:54 UTC
Description of problem:

With multipath, all the different paths for a device trigger the same by-uuid rule.  It tries to make the uuid symlink for every path, but only the first one succeeds.  The others fail with File exists.

Jun 22 16:33:50 redhat02 udevd-work[59824]: symlink(../../sdd, /dev/disk/by-id/scsi-350002ac000091534.udev-tmp) failed: File exists
Jun 22 16:33:50 redhat02 udevd-work[59824]: symlink(../../sdd, /dev/disk/by-id/wwn-0x50002ac000091534.udev-tmp) failed: File exists
Jun 22 16:34:22 redhat02 udevd-work[59844]: symlink(../../sdw, /dev/disk/by-id/wwn-0x50002ac000101534.udev-tmp) failed: File exists
Jun 22 16:36:50 redhat02 udevd-work[59799]: rename(/dev/disk/by-id/wwn-0x50002ac000091534.udev-tmp, /dev/disk/by-id/wwn-0x50002ac000091534) failed: No such file or directory
Jun 22 16:37:31 redhat02 udevd-work[13160]: rename(/dev/disk/by-id/scsi-350002ac0000d1534.udev-tmp, /dev/disk/by-id/scsi-350002ac0000d1534) failed: No such file or directory
Jun 22 16:37:31 redhat02 udevd-work[13160]: rename(/dev/disk/by-id/wwn-0x50002ac0000d1534.udev-tmp, /dev/disk/by-id/wwn-0x50002ac0000d1534) failed: No such file or directory
Jun 22 16:38:14 redhat02 udevd-work[59791]: symlink(../../sdx, /dev/disk/by-id/wwn-0x50002ac000101534.udev-tmp) failed: File exists
Jun 22 16:39:22 redhat02 udevd-work[59850]: rename(/dev/disk/by-id/scsi-350002ac0000d1534.udev-tmp, /dev/disk/by-id/scsi-350002ac0000d1534) failed: No such file or directory
Jun 22 16:39:38 redhat02 udevd-work[59824]: rename(/dev/disk/by-id/scsi-350002ac0000f1534.udev-tmp, /dev/disk/by-id/scsi-350002ac0000f1534) failed: No such file or directory
Jun 22 16:40:10 redhat02 udevd-work[59857]: symlink(../../sdp, /dev/disk/by-id/wwn-0x50002ac0000d1534.udev-tmp) failed: File exists
Jun 22 16:40:46 redhat02 udevd-work[59817]: rename(/dev/disk/by-id/scsi-350002ac0000f1534.udev-tmp, /dev/disk/by-id/scsi-350002ac0000f1534) failed: No such file or directory
Jun 22 16:41:23 redhat02 udevd-work[59791]: symlink(../../sdt, /dev/disk/by-id/scsi-350002ac0000f1534.udev-tmp) failed: File exists
Jun 22 16:43:44 redhat02 udevd-work[13166]: symlink(../../sdt, /dev/disk/by-id/scsi-350002ac0000f1534.udev-tmp) failed: File exists
Jun 22 16:44:43 redhat02 udevd-work[13166]: symlink(../../sdw, /dev/disk/by-id/wwn-0x50002ac000101534.udev-tmp) failed: File exists
Jun 22 16:46:59 redhat02 udevd-work[59791]: symlink(../../sdd, /dev/disk/by-id/scsi-350002ac000091534.udev-tmp) failed: File exists
Jun 22 16:47:26 redhat02 udevd-work[59869]: symlink(../../sdag, /dev/disk/by-id/scsi-350002ac000101534.udev-tmp) failed: File exists
Jun 22 16:47:26 redhat02 udevd-work[59869]: rename(/dev/disk/by-id/wwn-0x50002ac000101534.udev-tmp, /dev/disk/by-id/wwn-0x50002ac000101534) failed: No such file or directory
Jun 22 16:47:50 redhat02 udevd-work[59824]: rename(/dev/disk/by-id/scsi-350002ac0000f1534.udev-tmp, /dev/disk/by-id/scsi-350002ac0000f1534) failed: No such file or directory
Jun 22 16:48:33 redhat02 udevd-work[59791]: rename(/dev/disk/by-id/wwn-0x50002ac0000f1534.udev-tmp, /dev/disk/by-id/wwn-0x50002ac0000f1534) failed: No such file or directory
Jun 22 16:49:35 redhat02 udevd-work[59817]: rename(/dev/disk/by-id/wwn-0x50002ac000101534.udev-tmp, /dev/disk/by-id/wwn-0x50002ac000101534) failed: No such file or directory
Jun 22 16:51:07 redhat02 udevd-work[59792]: symlink(../../sdt, /dev/disk/by-id/wwn-0x50002ac0000f1534.udev-tmp) failed: File exists
Jun 22 16:51:26 redhat02 udevd-work[59884]: rename(/dev/disk/by-id/scsi-350002ac000101534.udev-tmp, /dev/disk/by-id/scsi-350002ac000101534) failed: No such file or directory
Jun 22 16:51:40 redhat02 udevd-work[59869]: rename(/dev/disk/by-id/scsi-350002ac0000f1534.udev-tmp, /dev/disk/by-id/scsi-350002ac0000f1534) failed: No such file or directory
Jun 22 16:52:50 redhat02 udevd-work[59817]: symlink(../../sdp, /dev/disk/by-id/scsi-350002ac0000d1534.udev-tmp) failed: File exists
Jun 22 16:53:44 redhat02 udevd-work[13166]: symlink(../../sdm, /dev/disk/by-id/scsi-350002ac0000d1534.udev-tmp) failed: File exists
Jun 22 16:54:03 redhat02 udevd-work[59792]: symlink(../../sdx, /dev/disk/by-id/scsi-350002ac000101534.udev-tmp) failed: File exists
Jun 22 16:54:33 redhat02 udevd-work[13166]: rename(/dev/disk/by-id/scsi-350002ac000101534.udev-tmp, /dev/disk/by-id/scsi-350002ac000101534) failed: No such file or directory

Version-Release number of selected component (if applicable):
2.6.32-131.0.15.el6.x86_64
libgudev1-devel-147-2.35.el6.x86_64
udev-147-2.35.el6.x86_64
libudev-147-2.35.el6.x86_64
libgudev1-147-2.35.el6.x86_64
python-gudev-147.1-4.el6_0.1.x86_64
libudev-devel-147-2.35.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
server is throwing failed messages

Expected results:
server should not throwing any message 

Additional info:

Comment 2 Harald Hoyer 2012-07-09 14:17:55 UTC
did you turn on debug or did you strace?

Comment 3 Harald Hoyer 2012-07-09 14:24:11 UTC
ah, sorry.. I see, it's a real error message... Seems to be a race.

Comment 4 mjin 2012-07-12 01:29:39 UTC
customer wants to know the progress of this bug, so i am changing view right from Red Hat Employee (internal) -> ALL, 

Please correct me if something wrong with such action,

Comment 5 Harald Hoyer 2012-07-12 08:47:36 UTC
(In reply to comment #4)
> customer wants to know the progress of this bug, so i am changing view right
> from Red Hat Employee (internal) -> ALL, 
> 
> Please correct me if something wrong with such action,

no problem

We have a solution, which basically circumvents the error message, but not the outcome.

Comment 6 Kay Sievers 2012-07-12 12:09:37 UTC
> (In reply to comment #4)
> > customer wants to know the progress of this bug

As Harald said, the "fix" is to suppress the message of racing events
fighting about the same symlink name. It's nothing udev could work
around or solve.

There will be no change in behaviour, besides that it is not logged any more.

Comment 13 errata-xmlrpc 2013-02-21 10:29:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0435.html


Note You need to log in before you can comment on or make changes to this bug.