Bug 838465 - [RFE] User portal : Allow an administrator to restrict a user to only create VMs from templates
[RFE] User portal : Allow an administrator to restrict a user to only create ...
Status: CLOSED DUPLICATE of bug 874328
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Omer Frenkel
Yaniv Kaul
virt
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 04:02 EDT by Andrew Cathrow
Modified: 2014-09-07 18:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 18:07:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cathrow 2012-07-09 04:02:15 EDT
Use case :

We want to restrict certain users to only be able to build VMs from templates and not be allowed to customize anything apart from the name and the timezone.

I'd suggest that we have a new permission for creating 'custom' VMs.
Comment 1 Itamar Heim 2012-07-09 05:10:34 EDT
this is far from trivial, it means we need to give a user a permission to create VM without getting the VM Owner role on it, only the VMLimitedOwner (run, delete) or something like that.
and even then, prevent run once to that users, etc.
Comment 2 Andrew Cathrow 2012-11-07 18:07:51 EST
Closing - let's handle as part of 3.2 templates (instance types, etc)

*** This bug has been marked as a duplicate of bug 874328 ***

Note You need to log in before you can comment on or make changes to this bug.