This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 838482 - ip route show does not print correct value when larger rto_min is set
ip route show does not print correct value when larger rto_min is set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute (Show other bugs)
6.2
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Petr Šabata
David Spurek
:
: 959640 (view as bug list)
Depends On:
Blocks: 832743
  Show dependency treegraph
 
Reported: 2012-07-09 04:43 EDT by Karel Srot
Modified: 2015-03-02 00:26 EST (History)
6 users (show)

See Also:
Fixed In Version: iproute-2.6.32-24.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:00:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-07-09 04:43:13 EDT
Description of problem:

"ip route show" doesn't print properly larger rto_min values

# ip route add 127.0.0.31 via 127.0.0.13 dev dummy0 rto_min 3000ms
# ip route show dev dummy0
127.0.0.31 via 127.0.0.13  rto_min lock 2ms

but works fine when rto_min is lower, e.g. 3ms.

This happens also for IPv6.

Probably upstream fix
http://mpls-linux.git.sourceforge.net/git/gitweb.cgi?p=mpls-linux/iproute2;a=patch;h=7c73e1bd21bc54b20b2d4ad0fc1a94ca0b76c285


Version-Release number of selected component (if applicable):
iproute-2.6.32-20.el6

How reproducible:
always
Comment 2 Travis Gummels 2013-05-07 20:43:17 EDT
*** Bug 959640 has been marked as a duplicate of this bug. ***
Comment 8 Petr Šabata 2013-08-14 09:04:16 EDT
Pushed as iproute-2.6.32-24.el6.
Comment 12 errata-xmlrpc 2013-11-21 18:00:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1697.html

Note You need to log in before you can comment on or make changes to this bug.