Bug 838487 - [RFE] Allow setting of machine type per VM rather than cluster level
Summary: [RFE] Allow setting of machine type per VM rather than cluster level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Michal Skrivanek
QA Contact: sefi litmanovich
URL: http://www.ovirt.org/Features/Cluster...
Whiteboard:
Depends On: 1236049
Blocks: 1302707
TreeView+ depends on / blocked
 
Reported: 2012-07-09 09:00 UTC by Andrew Cathrow
Modified: 2017-02-27 12:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1236049 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:26:48 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 31580 None ABANDONED core: Cluster parameters override - backend Never
oVirt gerrit 31581 master MERGED restapi: Cluster parameters override Never
oVirt gerrit 31582 master MERGED userportal\webadmin: cluster parameters override Never
oVirt gerrit 32546 master MERGED core: Cluster parameters override - fields\db Never
oVirt gerrit 32547 master MERGED core: Cluster parameters override - OVF Never
oVirt gerrit 32548 master MERGED core: Cluster parameters override - scheduler \ actions \ queries Never
oVirt gerrit 34974 master MERGED core: Fix naming in CpuFlagsManagerHandler Never
oVirt gerrit 38407 master MERGED userportal/webadmin: cluster parameters override - UI enhancements Never

Description Andrew Cathrow 2012-07-09 09:00:42 UTC
Today the machine type (eg. -M 6.3.0) is taken from the cluster level.
We need the ability for a user to specify the machine type per VM.

We need to research if we just use the qemu machine type or if we have to extend this and have a compatibility schedule that encompasses more than just the -M flag.

Comment 1 Michal Skrivanek 2012-09-26 11:20:24 UTC
let's start with -M setting only.
currently in vdc_options per cluster level.
Need default selection in cluster dialog and override in VM dialog

Comment 2 Itamar Heim 2012-09-28 07:14:40 UTC
since we can't tell what's tested per -M level, i think the appraoch should be to specify the VM cluster compatibility level.
then for example, the list of allowed cpu's (there is another RFE to select this one) would be based on the vm compat level.
same for validation on operations (maybe we don't allow to hotplug a nic to a VM which is in an older cluster level).

i.e., not sure we should handle the -M directly, rather than the compat level.

Comment 3 Itamar Heim 2013-04-01 09:43:24 UTC
Andrew - please elaborate on reason for this feature and expected behavior.
there is quite a lot of complexity/risk around manging this wrt testing since we have no way to distinguish which features get tested at a specific cluster compatibility level based on -M of qemu-kvm.

Comment 5 Itamar Heim 2013-12-01 08:01:37 UTC
andrew, the default for VMs would be "cluster default", right?
so on change of cluster to 4.0, all VMs will boot with -M rhel7, unless admin specifically changes it to say "3.5"?
would we do this based on rhel versions, or rhev cluster compatibility versions?

Comment 6 Andrew Cathrow 2013-12-03 09:00:57 UTC
(In reply to Itamar Heim from comment #5)
> andrew, the default for VMs would be "cluster default", right?

Yes

> so on change of cluster to 4.0, all VMs will boot with -M rhel7, unless
> admin specifically changes it to say "3.5"?

Yes

> would we do this based on rhel versions, or rhev cluster compatibility
> versions?

IMHO rhev cluster compatibility levels

Comment 11 sefi litmanovich 2016-01-03 13:20:33 UTC
Verified with rhevm-3.6.2-0.1.el6.noarch according to attached test plan.
Test run:

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3_6_VIRT_Cluster_Parameters_Override_23122015

Comment 14 errata-xmlrpc 2016-03-09 20:26:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.