Bug 838490 - [RFE] Specify CPU per VM - lower or equal than cluster cpu, or non-migratable
[RFE] Specify CPU per VM - lower or equal than cluster cpu, or non-migratable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Michal Skrivanek
sefi litmanovich
http://www.ovirt.org/Features/Cluster...
: FutureFeature
Depends On: 1236049
Blocks: 952238 1302707
  Show dependency treegraph
 
Reported: 2012-07-09 05:05 EDT by Andrew Cathrow
Modified: 2016-07-13 05:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: ovirt-3-6-0-2
Doc Type: Enhancement
Doc Text:
Some cluster parameters can now be overridden on a per VM basis. See http://www.ovirt.org/Features/Cluster_parameters_override for detailed description
Story Points: ---
Clone Of:
: 952238 (view as bug list)
Environment:
Last Closed: 2016-03-09 15:26:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 32546 master MERGED core: Cluster parameters override - fields\db Never

  None (edit)
Description Andrew Cathrow 2012-07-09 05:05:24 EDT
Today the CPU type is taken from the cluster level
eg.If the cluster is Westmere then all the VMs are launched with -cpu westmere

We need the ability to specify CPU per virtual machine.
The setting should allow the cluster type or any lower CPU level
Comment 1 Itamar Heim 2013-04-01 05:33:04 EDT
Andrew - can you please elaborate on goal/reason here?
we have the -cpu host for performance.
I assume you don't want someone to set a VM to a lower cpu, rather only to a higher one, which may make it impossible to migrate, etc.

is this supposed to be like -cpu host, but "hopefully migrate-able"?

(switching to sla, as main consideration here will be scheduling)
Comment 2 Andrew Cathrow 2013-04-07 22:06:59 EDT
User cases

1. Allow a virtual machine to maintain a static CPU configuration.
eg. User is running VM on westmere host and upgrades the host systems to sandybridge.
Just because we are using a SandyBridge based host it doesn't mean we want to expose that to the guest. The guest may need to keep a consistent CPU and hardware profile.

2. Best performance (+ migration and stability)
- 10 node cluster. 
- 8 nodes are westmere, 2 are sandybridge
- Cluster level set to "westmere"

Allow admin to run VM with hardcoded "sandybridge" CPU on one of the 2 applicable hosts. Support migration between compatible hosts.

Obviously this brings with it restrictions.
- If no sandbridge system is running (or has capacity) then the VM can't be run
- You can only migrate between the 2 sandybridge machines
- If only one sandybridge machine is running the host won't be able to go into maintenance mode since it can't live migrate to another host so the VM will need to be stopped first.
Comment 3 Itamar Heim 2013-04-15 08:45:56 EDT
I've created bug 952238 as a clone of this bug for the more complex 2nd use case.

so 1st use case can cover the simpler modes:
- VM can be set to any cpu model *lower or equal* than cluster model without pinning (for static configuration)
- VM can be set to any cpu model higher than cluster model in non-migratable mode.
Comment 9 sefi litmanovich 2016-01-03 08:20:11 EST
Verified with rhevm-3.6.2-0.1.el6.noarch according to attached test plan.
Test run:

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3_6_VIRT_Cluster_Parameters_Override_23122015
Comment 12 errata-xmlrpc 2016-03-09 15:26:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.