Bug 838505 - rhc-chk fails to check domain status
rhc-chk fails to check domain status
Status: CLOSED DUPLICATE of bug 836483
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 05:37 EDT by jizhao
Modified: 2015-05-14 22:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 05:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-07-09 05:37:06 EDT
Description of problem:
Run rhc-chk and get error message. Starting ssh-agent and ssh-add your secret key doesn't change the result.

Version-Release number of selected component (if applicable):
rackframework-jizhao7.dev.rhcloud.com
rhc-0.95.8-1.el6_3.noarch

How reproducible:
Always

Steps to Reproduce:
1.Run rhc-chk
$ rhc-chk -l <rhlogin>
2.
3.
  
Actual results:
<------------------------output----------------------->
Loaded suite /usr/bin/rhc-chk
Started
.EF.FFF

  1) Error:
test_connectivity(Test1_Connectivity):
ArgumentError: too few arguments
    /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:207:in `sprintf'
    /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:207:in `error_for'
    /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:273:in `test_connectivity'

  2) Failure:
test_authentication(Test2_Authentication) [/usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:283]:
You need to be able to connect to the server in order to test authentication.
<false> is not true.

  3) Failure:
test_02_ssh_agent(Test3_SSH)
    [/usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:343:in `require_agent_keys'
     /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:373:in `test_02_ssh_agent']:
Either ssh-agent is not running or you do not have any keys loaded
If this is your only error, your connection may still work, depending on your SSH configuration.

  4) Failure:
test_03_remote_ssh_keys(Test3_SSH)
    [/usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:320:in `require_login'
     /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:324:in `require_remote_keys'
     /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:379:in `test_03_remote_ssh_keys']:
You must have an account on the server in order to test: whether you have a valid key loaded in your agent.

  5) Failure:
test_04_ssh_connect(Test3_SSH)
    [/usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:320:in `require_login'
     /usr/lib/ruby/gems/1.8/gems/rhc-0.95.8/bin/rhc-chk:386:in `test_04_ssh_connect']:
You must have an account on the server in order to test: connecting to your applications.

Finished in 12.645102 seconds.

7 tests, 8 assertions, 4 failures, 1 errors, 0 pendings, 0 omissions, 0 notifications
28.5714% passed

0.55 tests/s, 0.63 assertions/s
<-------------------------------------------->

Expected results:
rhc-chk should be run without error.

Additional info:
rhc domain status also get the same error.
Comment 1 Xiaoli Tian 2012-07-09 05:59:16 EDT

*** This bug has been marked as a duplicate of bug 836483 ***

Note You need to log in before you can comment on or make changes to this bug.