Bug 838512 - Tuned tries to remount a device mounted more than once on the system and fails
Tuned tries to remount a device mounted more than once on the system and fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tuned (Show other bugs)
6.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
Branislav Blaškovič
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 06:06 EDT by Vadim Grinco
Modified: 2013-11-21 06:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The "mount" command is used to remount file systems with no_barriers, but not all file systems can be remounted. Consequence: The remount command can fail and error message can be displayed which may confuse users. Fix: The error messages from the mount command were silenced. Result: If the file system cannot be remounted with no_barriers, it is silently skipped and no error is displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:33:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (524 bytes, patch)
2013-07-23 16:16 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Vadim Grinco 2012-07-09 06:06:55 EDT
Description of problem:
/etc/tune-profiles/enterprise-storage/ktune.sh (and probably others) is not able to correctly mount a GFS2 volume mounted twice or more times on the same system with the same journal id.

Version-Release number of selected component (if applicable):
tuned-0.2.19-7.el6.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Configure /dev/<path_to>/<gfs2_volume> to mount to /mnt/a and /mnt/b in /etc/fstab
2. Reboot system
  
Actual results:
ktune.sh tries to mount /mnt/a and /mnt/b with nobarrier option, which is impossible in the configuration above.

Expected results:
Exclude /mnt/a and /mnt/b from the list of devices that have to be mounted with nobarrier option.
Comment 2 RHEL Product and Program Management 2012-09-07 01:34:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Jaroslav Škarvada 2013-07-22 12:55:17 EDT
I will just silence the error, because remounting local mounts with nobarrier can pass:

# mount
...
/dev/loop0 on /var/tmp/a type gfs2 (rw)
/dev/loop0 on /var/tmp/b type gfs2 (rw)

# mount -o remount,barrier=0 /var/tmp/a

# mount
...
/dev/loop0 on /var/tmp/a type gfs2 (rw,nobarrier)
/dev/loop0 on /var/tmp/b type gfs2 (rw)
Comment 7 Jaroslav Škarvada 2013-07-23 16:16:16 EDT
Created attachment 777456 [details]
Proposed fix
Comment 9 Branislav Blaškovič 2013-09-30 02:53:02 EDT
As mentioned in comment #6, there is no need for automatic test in my opinion. Patch looks sane and it applies correctly.

Marking Sanity only.
Comment 10 errata-xmlrpc 2013-11-21 06:33:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1623.html

Note You need to log in before you can comment on or make changes to this bug.