Bug 838524 - Votequorum should register reload callback only once
Summary: Votequorum should register reload callback only once
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.3
Hardware: All
OS: All
low
low
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-09 11:30 UTC by Jan Friesse
Modified: 2013-02-21 07:50 UTC (History)
2 users (show)

Fixed In Version: corosync-1.4.1-8.el6
Doc Type: Bug Fix
Doc Text:
Cause Corosync running with votequorum enabled. Consequence Votequorum register reload configuration handler after each change in confdb. This will cause in the beginning slow down of corosync and resulting to OOM, ... Fix Register callback only at startup Result No slowdown, OOM, ...
Clone Of:
Environment:
Last Closed: 2013-02-21 07:50:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch (1.76 KB, patch)
2012-07-09 11:30 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0497 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-02-20 21:18:24 UTC

Description Jan Friesse 2012-07-09 11:30:07 UTC
Created attachment 597045 [details]
Proposed patch

Description of problem:
Votequorum should register reload callback only once and not after each
change in confdb.

Version-Release number of selected component (if applicable):
Flatiron

How reproducible:
100%

Steps to Reproduce:
1. Load votequorum plugin
2. corosync-objctl -c .usr
3. In log is corosync [VOTEQ ] Reading configuration
4. corosync-objctl -c .usr
5. In log appear another "corosync [VOTEQ ] Reading configuration" this time twice
6. corosync-objctl -c .usr
7. In log appear another "corosync [VOTEQ ] Reading configuration" this time three times
...

Actual results:
Votequorum register reload configuration handler after each change in confdb.

Expected results:
Votequorum register reload configuration handler only once.

Comment 3 Jan Friesse 2012-08-06 10:25:43 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Corosync running with votequorum enabled.

Consequence
Votequorum register reload configuration handler after each change in confdb. This will cause in the beginning slow down of corosync and resulting to OOM, ...

Fix
Register callback only at startup

Result
No slowdown, OOM, ...

Comment 5 Jaroslav Kortus 2012-12-03 13:41:38 UTC
with this snip in corosync.conf:
quorum {
	provider: corosync_votequorum
}

and debug set to on the following happens:

* corosync-objctl -w quorum.expected_votes
corosync [VOTEQ ] Reading configuration

* corosync-objctl -c qa; corosync-objctl -w qa.test=1
[ nothing from VOTEQ in logs ]

Behaves as expected. corosync-1.4.1-12.el6.x86_64.

Comment 7 errata-xmlrpc 2013-02-21 07:50:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0497.html


Note You need to log in before you can comment on or make changes to this bug.