Bug 838585 - Telepathy-Rakia SIP support package missing files
Telepathy-Rakia SIP support package missing files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: telepathy-kde-accounts-kcm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 10:28 EDT by Alan Schmidt
Modified: 2012-07-19 04:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 04:52:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 302972 None None None 2012-07-09 11:19:40 EDT

  None (edit)
Description Alan Schmidt 2012-07-09 10:28:09 EDT
Pursuant to https://bugs.kde.org/show_bug.cgi?id=302972:

Without duplicating the entire thread of the bug above, it would seem that telepathy-rakia's account manager UI is a little bit broken. There is a thought that the following files should be present, but are missing:

/usr/lib/kde4/ktpaccountskcm_plugin_rakia.so
/usr/share/kde4/services/ktpaccountskcm_plugin_rakia.desktop

There is a thought that these files might possibly have different locations in Fedora. However "locate ktpaccountskcm_plugin_rakia.so" and "locate ktpaccountskcm_plugin_rakia.desktop" do not find them.

Also, I don't seem to see anything that looks likely in a different location when I do "rpm -ql telepathy-rakia"
Comment 1 Brian Pepple 2012-07-09 11:16:29 EDT
Those files wouldn't be shipped with tp-rakia, but with the IM client (which looks to be the KDE client) that uses tp-rakia. I'm guessing telepathy-kde-accounts-kcm is the correct component, but since I'm not a KDE user someone more knowledgable can make sure it's assigned to the right place.
Comment 2 Rex Dieter 2012-07-09 11:19:40 EDT
Kde telepathy upstream asked me to not include rakia support (hence not included), since it was deprecated or that there were some better options.

I guess I'll have to ask them again.
Comment 3 Rex Dieter 2012-07-09 11:23:17 EDT
Martin,

did I mess up here? :)  is rakia support worth including in our packaging?
Comment 4 Brian Pepple 2012-07-09 11:24:02 EDT
Rex, I think upstream might have got their wires crossed on this, since if I remember correctly telepathy-rakia replaced the old telepathy sip (tp-sofiasip).
Comment 5 Martin Klapetek 2012-07-09 12:04:13 EDT
You are both correct - telepathy-rakia deprecated telepathy-sofia, but it wasn't really supported because we (kde-telepathy) support only Call1 spec for audio/video calls, which was very recently added to telepathy-rakia, which we now support again, so ktp-accounts-kcm should again install files for rakia. But you also need telepathy-rakia-0.7.4 in order for it to work, the previous versions won't work.

Everything else in ktp-accounts-kcm should stay the same.
Comment 6 Rex Dieter 2012-07-09 12:05:36 EDT
Yay, ok.  I'll fix up the packaging then.
Comment 7 Rex Dieter 2012-07-09 12:07:44 EDT
Brian, i see f16 only has telepathy-rakia-0.7.3, can we get a 0.7.4 update there, or would you rather I add this support to f17+ only?
Comment 8 Brian Pepple 2012-07-09 12:38:27 EDT
Rex, I'm not sure we should push tp-rakia-0.7.4 to f16 since that would require an update to tp-glib from 0.16.* to 0.17.*, and that could possibly adversely affect gnome-shell, folks, etc which use it. IMO it's probably best to only support this in f17+.
Comment 9 Martin Klapetek 2012-07-09 12:55:50 EDT
Hmm, thinking about it now - not installing the plugins does not solve much, because we still provide a fallback ui in case the plugin wasn't loaded, because the account is still offered in the list of "add new account". So ktp-accounts-kcm could be patched to not offer creating of SIP account completely, I'm just not sure it's "the right thing" to do. Maybe a dynamic detection of installed packages, ie. "if (isInstalled(tp-rakia) && hasVersionAtLeast(0.7.4)) { addRakiaAccountToTheList(); }" could help here. I /think/ we already use packagekit to detect gabble/haze.
Comment 10 Rex Dieter 2012-07-09 13:05:19 EDT
Brian, ok.

Martin, I added a dependency, Requires: telepathy-rakia  to ktp-accounts-kcm packaging.  chime in if you think that's ok, or whether you'd rather use something like the dynamic checking at runtime you mentioned.
Comment 11 Martin Klapetek 2012-07-09 14:09:36 EDT
I have no problems with a dependency on tp-rakia. In fact I favor it, there is already a dep on tp-gabble and tp-haze, right? So it makes sense to add tp-rakia there.
Comment 12 Rex Dieter 2012-07-09 14:14:26 EDT
correct
Comment 13 Fedora Update System 2012-07-09 14:42:00 EDT
ktp-accounts-kcm-0.4.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ktp-accounts-kcm-0.4.0-2.fc17
Comment 14 Fedora Update System 2012-07-10 12:21:23 EDT
Package ktp-accounts-kcm-0.4.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ktp-accounts-kcm-0.4.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10409/ktp-accounts-kcm-0.4.0-2.fc17
then log in and leave karma (feedback).
Comment 15 Alan Schmidt 2012-07-10 13:49:28 EDT
Got too excited and couldn't wait.

Downloaded update from:

http://koji.fedoraproject.org/koji/buildinfo?buildID=329640

The accounts screen for SIP now looks great and works great, and even connects.

Creating contacts for the SIP account seems to be an issue, but I think THIS item can be closed.

I thought maybe it was for me to close, but I got confused by the closed options, so I left it alone.
Comment 16 Rex Dieter 2012-07-10 14:03:20 EDT
No worries, thanks for testing.

the bug will get closed automatically once this fixed build lands in stable updates.
Comment 17 Fedora Update System 2012-07-19 04:52:27 EDT
ktp-accounts-kcm-0.4.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.