Bug 838596 - JON Agent RPM Errata Failure(s): Elfinit
JON Agent RPM Errata Failure(s): Elfinit
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.0
Unspecified Unspecified
high Severity high
: ---
: JON 3.3.0
Assigned To: Stefan Negrea
Mike Foley
:
Depends On: 838605 838601 838603
Blocks: 837381 837877
  Show dependency treegraph
 
Reported: 2012-07-09 10:45 EDT by Mike Foley
Modified: 2014-08-29 16:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837877
Environment:
Last Closed: 2014-08-29 16:11:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2012-07-09 10:45:04 EDT
+++ This bug was initially created as a clone of Bug #837877 +++

For issue #1 ... Elfinit.

https://errata.devel.redhat.com/rpmdiff/show/62412?result_id=1141638

Document the waiver, or fix.

--- Additional comment from mfoley@redhat.com on 2012-07-05 14:46:48 EDT ---

Created attachment 596470 [details]
errata failures for elfinit

--- Additional comment from mfoley@redhat.com on 2012-07-05 14:47:25 EDT ---

Created attachment 596471 [details]
errata failure for binary stripping

--- Additional comment from mfoley@redhat.com on 2012-07-05 14:47:56 EDT ---

Created attachment 596472 [details]
errata failure for ipv6

--- Additional comment from mfoley@redhat.com on 2012-07-05 14:48:37 EDT ---

Created attachment 596474 [details]
errata failure for execshield

--- Additional comment from snegrea@redhat.com on 2012-07-06 17:11:35 EDT ---

All these failures should be waived because the binary libraries are distributed (and have been distributed) in the regular agent packaging without any problems or issues raised. The files are part of the typical agent installation payload. A more detailed explanation for each failure or warning is presented below.


1) Elflint - Failure

Example failure message: 
libaugeas.so within payload for noarch is an Intel 80386 ELF file

Waiver explanation:
This failure is triggered because the agent RPM is marked as .noarch while the library is architecture specific. The RPM includes libraries for all supported architectures. This is a non-issue because the agent will determine which library to use at runtime.


2) Binary Stripping - Failure

Example failure message: 
libsigar-amd64-linux.so is not stripped of DWARF data on noarch

Waiver explanation:
The error message means that the particular library has not been stripped of debug information. The only side effects are larger libraries and the potential to reveal more information than it should about code structure. Since the library is external to the project, the only course of action is to report the problem to the respective community and update the library once fixed in future JON releases.

3) Execshield - Failure

Example failure message:
Program built without GNU_STACK: /usr/share/jboss-on-3.1.0.GA/agent/lib/libsigar-x86-linux.so on noarch

Waiver explanation:
This failure means that the library does not contain a GNU_STACK line but it requires executable stacks. Since the library is external to the project, the only course of action is to report the problem to the respective community and update the library once fixed in future JON releases.


4) IPV6 - Warning

Example failure message:
libsigar-amd64-linux.so on noarch uses function inet_addr, which may impact IPv6 support

Waiver explanation:
This warning means that the library is using deprecated symbols that could affect IPV6 support. Since the library is external to the project, the only course of action is to report the problem to the respective community and update the library once fixed in future JON releases.
Comment 1 Larry O'Leary 2012-07-09 10:50:04 EDT
This issue description from comment #0 should focus specifically on:

1) Elflint - Failure

Example failure message: 
libaugeas.so within payload for noarch is an Intel 80386 ELF file

Waiver explanation:
This failure is triggered because the agent RPM is marked as .noarch while the library is architecture specific. The RPM includes libraries for all supported architectures. This is a non-issue because the agent will determine which library to use at runtime.
Comment 2 Larry O'Leary 2012-07-09 10:53:44 EDT
To address this, RPM sub-packages[1] should be used. The user would then install the sub-package if they desired the functionality. Additionally, the 32-bit libraries required by the 32-bit library would only get installed when the user explicitly installed the 32-bit library. A 64-bit version would also be created containing the 64-bit binary. Essentially we would end up with rhq-agent-augeas package for i386 and rhq-agent-augeas for x86_64.



[1]: http://www.rpm.org/max-rpm/ch-rpm-subpack.html
Comment 5 Stefan Negrea 2014-08-29 16:11:03 EDT
This has been addressed via exceptions or fixes since the initial release of the agent RPM. Closing this as being implemented in the current release,

Note You need to log in before you can comment on or make changes to this bug.