Bug 838636 - region and language segfault when typing while languages are loading
region and language segfault when typing while languages are loading
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: beta
: 7.0
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 12:38 EDT by Vladimir Benes
Modified: 2012-10-16 04:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 04:12:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bt (10.58 KB, text/plain)
2012-07-09 12:40 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-07-09 12:38:16 EDT
Description of problem:
control-center segfaults when typing and searching for languages while languages are being loaded into dialog.. this can happen very often as you know what you are looking for.

Version-Release number of selected component (if applicable):
control-center-3.4.2-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.go into control-center and region and language 
2.click + to add language
3.type Cze while languages are being loaded
  
Actual results:
crash

Expected results:
no crash, language correctly found

Additional info:
backtrace attached
Comment 1 Vladimir Benes 2012-07-09 12:40:08 EDT
Created attachment 597104 [details]
bt
Comment 2 Vladimir Benes 2012-07-09 12:48:51 EDT
the same behavior is when typing in format tab
Comment 4 Bastien Nocera 2012-10-15 11:42:44 EDT
Setting a needinfo, as we cannot reproduce the bug in 3.6.
Comment 5 Vladimir Benes 2012-10-16 04:12:13 EDT
cannot reproduce either, closing as current release

Note You need to log in before you can comment on or make changes to this bug.